[Помогите] Шаблон страницы с формой, нет данных при постинге

Тема в разделе "Wordpress", создана пользователем Grafs, 24 янв 2009.

Статус темы:
Закрыта.
Модераторы: DzSoft, Sorcus
  1. Grafs

    Grafs Постоялец

    Регистр.:
    19 дек 2008
    Сообщения:
    75
    Симпатии:
    12
    Возникла проблема.
    Создал шаблон отдельной страницы на основе page.php
    Подключил все вродебы хорошо.
    На странице присутствует форма с различными полями и кнопка сабмит
    Заполняю форму нажимаю кнопку. Данные на страницу формы не приходят.
    Проверяю print_r($_Post); Пустой массив.
    В форме пробовал по разному:
    1. <form name="frm" action="www.domen.com/stranica" method="POST">
    2. <form name="frm" action="www.domen.com/... /stranica.php" method="POST">
    3. <form name="frm" action="www.domen.com/ с параметрами без ЧПУ" method="POST">
    4. <form name="frm" action="" method="POST">
    Все четыре способа не проходят.
    Может в Wordpress есть кактойто ньюанс типа перехвата POST или GET запросов.
    Мозги закипают.
    Что не так?
     
  2. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Для чего форма: комментарии или, что то другое ?
     
  3. vasiatka

    vasiatka Писатель

    Регистр.:
    21 янв 2009
    Сообщения:
    6
    Симпатии:
    0
    Дело не в Url. Мне кажется где-то данные обрезаются.
     
  4. Limmer

    Limmer

    Регистр.:
    3 июн 2008
    Сообщения:
    206
    Симпатии:
    45
    смотря для каких целей форма, вообще для нового поста я использую функцию
    PHP:
    wp_nonce_field'new-post' );
    подставляю между тегами form
     
  5. Grafs

    Grafs Постоялец

    Регистр.:
    19 дек 2008
    Сообщения:
    75
    Симпатии:
    12
    Форма - бланк заказа.
    Создаю как обычно на основе page.php шаблон страницы и подключаю к блогу.
    В исходнике в htmle форма - бланк заказа и скрипт на php для обработки форы.
    Все ок, но вот данные с формы не возвращаются в эту страницу для обработки скриптом.
     
  6. Grafs

    Grafs Постоялец

    Регистр.:
    19 дек 2008
    Сообщения:
    75
    Симпатии:
    12
    Все проблему решил, прикол вот в чем:
    В фрме присутствовало текстовое поле где в теге было указано name="name"
    При таком имени wp выкидывает на 404 страницу, а у меня шаблон так сделан что я этого не заметил. Теперь все ОК
     
Статус темы:
Закрыта.