Проблема в процессе установки PHPBB3

Тема в разделе "Коммерческие", создана пользователем Albert22, 23 янв 2009.

Информация :
Публиковать (для всех) нуленые версии, особенно от modulesgarden КАТЕГОРИЧЕСКИ не стоит. Тема мониторится оным разработчиком, а к нам приходят абузы которые нельзя игнорировать.
Статус темы:
Закрыта.
Модераторы: Amazko, Aste
  1. Albert22

    Albert22

    Регистр.:
    30 мар 2008
    Сообщения:
    270
    Симпатии:
    10
    Всем привет
    Скачал phpbb v. 3, начал пытаться установить (firstvds), но на этапе Welcome to Installation (появляется когда на вкладку Install перехожу) после нажатия Proceed to next step возникает вот такая жопа:
    Firefox выдаёт запрос на открытие/сохранение пустого файла index.php
    Opera и Safari предполагают что я ошибся адресом
    IE «Невозможно отобразить страницу»
    Что это может быть?
     
  2. astery

    astery Создатель

    Регистр.:
    2 ноя 2007
    Сообщения:
    33
    Симпатии:
    0
    Напиши детальнее что ты делаешь. Необходимо просто создать пустую базу в мускуле, далее просто зайти в папку /install/install.php (относительно твоего вебсервера, сайта) и ответить на вопросы...
     
  3. gls

    gls Комбат

    Регистр.:
    11 янв 2007
    Сообщения:
    555
    Симпатии:
    280
    Буквально вчера скачал phpbb 3.0.4 rus протестил на денвере под оперой все пучком - пашет только в путь
     
  4. Albert22

    Albert22

    Регистр.:
    30 мар 2008
    Сообщения:
    270
    Симпатии:
    10
    Детально, говоришь? :)
    Распаковал архив с форумом скачанный с официального сайта. Захожу браузером в директорию ./install, открывается индексный файл с текстом
    Вверху вкладки, среди неактивных — "Install". Перехожу туда, там текст
    При всём моём знании английского, ни одного упоминания о том, что БД для форума должна быть априори создана я не вижу. То есть БД для форума должна существовать начиная с того момента, когда к ней обращается инсталлятор. До этого момента её отсутствие никак не влияет. Процитировал текст полностью, т.к. может Вы найдёте там такое упоминание... :)
    Отвлёкся. Далее жму "Proceed to next step", кнопка становится неактивной, что-то грузится, и ФФ выдаёт запрос на сохранение пустого файла index.php. О том, что делают другие браузеры, я написал выше.

    Кстати, отмечу что vBulletin (нулёный, конечно) тоже отказался становиться — ругался на какие-то XML функции. «Не судьба», — решил я и передумал его ставить.
    Причём, в то же время скрипт в соседней директории парсит XML фиды с last.fm'a только так...
     
  5. khlamaster

    khlamaster Создатель

    Регистр.:
    7 ноя 2008
    Сообщения:
    19
    Симпатии:
    0
    попробуй инсталл перезалить. у меня на хосте 3 форума в этой версии работают, и на денвере парочка, проблем с установкой не было вообще. С кодировкой были правда, но пока тьфу-тьфу-тьфу :)

    про БД, все верно, базу можно создавать когда инсталятор попросит ввести ДБ нэйм и т.д.
     
  6. Caller

    Caller Создатель

    Регистр.:
    29 июл 2008
    Сообщения:
    18
    Симпатии:
    2
    Проверь CHMOD, возможно проблема в них
     
  7. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    760
    Симпатии:
    198
    Возможно файлы были залиты не в той кодировке. php, html, cfg и т.д. нудно заливать в ASCII, а img, jpg и т.д. в BINARY.
    Ну и пред тем как нажимать инсталл CHMOD на config.php должен быть 666, после установки 644 как собственно и все остальные файлы.
     
  8. elsinor

    elsinor Прохожие

    firstvds плохо дружит с phpbb3. проверено лично. лично я юзаю moinet уже пол-года и проблем 0
     
Статус темы:
Закрыта.