Какой заголовок отправляете в WAP-скриптах?

Тема в разделе "WAP", создана пользователем lamo, 20 янв 2009.

Статус темы:
Закрыта.
  1. lamo

    lamo Постоялец

    Регистр.:
    1 июл 2008
    Сообщения:
    51
    Симпатии:
    4
    У меня не грузится WAP-сайт на некоторых телефонах (в т.ч. на СониЭриксоне 550Z) сами скрипты у меня *.php. Вот такой заголовок посылаю:
    Код:
    <?
     header("Content-type:text/vnd.wap.wml;charset=utf-8");
     print "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n";
     print "<!DOCTYPE wml PUBLIC \"-//WAPFORUM//DTD WML 1.1//EN\" \"http://www.wapforum.org/DTD/wml_1.1.xml\">";
     print "<wml>\n";
     print "<meta http-equiv=\"Cache-Control\" content=\"no-store, no-cache, must-revalidate, post-check=0, pre-check=0\"/>\n";
     print "<card id=\"card1\" title=\"Sitename.RU\">\n";
    ?>
    При этом в Опере и на моей Nokia N81 работает все отлично :( Подскажите плиз в чем мои ошибки?
     
  2. Ser Frood

    Ser Frood Заблокирован

    Регистр.:
    12 дек 2006
    Сообщения:
    522
    Симпатии:
    386
    Код:
     <?
    header("Cache-Control: no-cache");
    header("Content-type:text/vnd.wap.wml");
    echo '<?xml version="1.0" encoding="UTF-8"?>';
    echo '<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.2//EN" "http://www.wapforum.org/DTD/wml12.dtd">';
    echo '<wml><head><meta http-equiv="Cache-Control" content="no-cache" forua="true"/></head>';
    echo '<card title="YO"><p align="center"><small>';
    
    echo 'h1';
    
    echo '</small></p></card></wml>';
    ?>
     
    Cannabis69 и lamo нравится это.
Статус темы:
Закрыта.