1. Важное и срочное обновление IPB 3.4.5 - https://nulled.cc/threads/243375/

Ошибка после обновления IPB

Тема в разделе "IPB", создана пользователем Hang, 12 фев 2007.

Статус темы:
Закрыта.
Модераторы: Maybe
  1. Hang

    Hang Прохожие

    Ребята помогите, обновился с 2.1.7 на 2.2.1 и теперь админка пашет а на главную форума зайти не могу выдаёт эту ошибку
    Код:
    Parse error: syntax error, unexpected '(', expecting T_VARIABLE or '$' in /home/exd/public_html/forum/cache/skin_cache/cacheid_11/skin_global.php on line 465
    
    где в скриптике cacheid_11/skin_global.php в строке 465 вот что
    Код:
    строка 464 //startif
    строка 465 if ( $($this->ipsclass->input['act'] == 'sf' OR $$this->ipsclass->input['act'] == 'st') AND $$this->ipsclass->input['f'] )
    Воообще не пойму что случилось и что делать.
     
  2. WebeX

    WebeX Постоялец

    Заблокирован
    Регистр.:
    8 фев 2007
    Сообщения:
    277
    Симпатии:
    129
    Попробуй две версии файла сравнить или накрайняк последний просто заменить а потом посмотришь что будет!
     
  3. Softinka

    Softinka Прохожие

    В общем, старый шаблон не подходит, нужно переделывать стандартный под старый вид или старый дорабатывать.
     
  4. Antox

    Antox Создатель

    Регистр.:
    4 фев 2007
    Сообщения:
    38
    Симпатии:
    0
    Hang поздно говорить но обновляться не надо было..А так по теме:перепиши файл с дистрибутива 2.2.1 я думаю ничего не потеряешь!
     
  5. Hang

    Hang Прохожие

    Вобщем забил я на это дело поднял бекап базы и вернул старую добрую 2.1.7 Наделал немного модов и решил на этой версии пустить корни, тоисть больше не обновлятся так как особо то и не шарю сильно в php.
    Хотя догадываюсь почему форум обновился с ошибками я его уже немного модефецировал до этого да и обновлял его в течении 2х лет от версии1.3 и видимо он задолбался ужо обновлятся :)
    зы Перейти по ссылке
     
Статус темы:
Закрыта.