php_mbstring.dll на php4

Тема в разделе "Администрирование серверов", создана пользователем Смоленский, 11 ноя 2008.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Apache/1.3.34 (Win32) PHP/4.4.9

    Не запускается модуль mbstring на php подключённом как mod_php к apache.

    В php.ini:
    Код:
    extension_dir = "d:/server/php/extensions"
     
    extension=php_mbstring.dll
    extension=php_gd2.dll
    Обе dll находятся в каталоге extensions и при запуске php как CGI работают, при запуске php кам модуля php_gd2.dll загружается а на php_mbstring.dll апач ругается, что её нет, в логе апача следующие сообщение:

    Небольшое добавление в сети встретилась информация, что если версия библиотеки не совпадает с версией php, то php выдает просто "не найден модуль", но в моём случае php скачано с
    php-4.4.9-Win32.zip
    и сомнения, что версии разные у меня небольшие, тем более что как я писал выше php_mbstring.dll под PHP CGI прекрасно работает.

    Что можно предпринять ?
     
  2. Muntik

    Muntik

    Регистр.:
    3 июн 2008
    Сообщения:
    451
    Симпатии:
    87
    php_mbstring.dll кинь в папку /php
     
  3. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Не помогает, так же на буржуйских форумах встречал информацию, что эту библиотеку от php5 необходимо добавить в windows, system32 попробывал повторить с php4 но не прокатывает, библиотека не подхватывается.
     
Статус темы:
Закрыта.