[Помогите] Проблема после обновления

Тема в разделе "Wordpress", создана пользователем Mons, 19 окт 2008.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. Mons

    Mons

    Регистр.:
    2 апр 2006
    Сообщения:
    1.590
    Симпатии:
    920
    Обновился с 2.5 до версии 2.6.2

    И теперь http://blog.mons.ws/index.php

    в админку не пускает.
     
  2. judgefog

    judgefog

    Регистр.:
    12 авг 2006
    Сообщения:
    487
    Симпатии:
    335
    база между этими версиями не менялась
    значит скрипты криво скопировались
    по фтп стирай руками файлы системы и лей с нуля (конфиг, тему и плагины не трогай)
     
  3. Mons

    Mons

    Регистр.:
    2 апр 2006
    Сообщения:
    1.590
    Симпатии:
    920
    это было сделано в первую очередь.
    Все удалено кроме конфига и папки wp-contents
    Затем залиты новые файлы и произведено обновление базы
    Однако ошибки не пропали. Грешу на битую базу.
     
  4. nautilus

    nautilus Постоялец

    Регистр.:
    4 ноя 2007
    Сообщения:
    83
    Симпатии:
    25
    файл /public_html/blog/wp-includes/widgets.php скорее всего сохранёе в кодировке UTF-8 с сигнатурой (BOOM).



    исправить:
    - Открыть программой Notepad++
    - Format -> Encode in UTF-8 without BOM
    - Жмем «Сохранить» и заливаем заново на хост
     
  5. Mons

    Mons

    Регистр.:
    2 апр 2006
    Сообщения:
    1.590
    Симпатии:
    920
    Это уже тоже делалось программой PSpad.
    Принудительно выставлял UTF-8 сохранял и заливал.
    Однако перед этим возник вопрос, а нахрена если фаил исходный с дистрибутиваи в иной кодировке он сохранен быть не может.

    У меня просьба не юзать гугл. Знаниями не блестнете. Я уже прошерстил все что только можно. Резуьтатов на данный момент ноль. Реинстал не выход. :nezn:
     
  6. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    1. Друг а как именно в админку не пускает пароль не правильный, белая страница авторизации, перкидывает куда то ?

    2. По поводу widgets.php а если устанавливаешь снова 2.5 то все нормально или такая же борода ?
     
  7. Mons

    Mons

    Регистр.:
    2 апр 2006
    Сообщения:
    1.590
    Симпатии:
    920
    Уже вылечил.

    Страница с ошибками причем с теми же что и при заходе на блог были.

    Нет. Она появилась при перезде. И откатывать то некуда было.


    Были проблемы с запуском. Вылечил, удалением всего, обновлением и сборкой бд по строчно ручками и потом обновив базу еще раз. Все ошибки виджетов лезли и изменения заголовка файлов. Советы сапорта не помогли. Сделал сам. Думаю обновление тут было не причем. Косяк был в том что совпал апгрейд и перезд на новый сервер
     
Статус темы:
Закрыта.