[DLE] [HELP] Комментарии

Тема в разделе "Скины", создана пользователем sesharim, 18 окт 2008.

Статус темы:
Закрыта.
  1. sesharim

    sesharim

    Регистр.:
    4 окт 2006
    Сообщения:
    297
    Симпатии:
    26
    Не работаю смайлы и bbcode в комментариях. При нажатии на смайл меня перебрасывает в верх страницы ! bbcode просто не вставляются ! Двиг чистый ! Думаю дело в шаблоне но ничего не могу понять! Шаблон из " убожества маккоя"

    addcomments.tpl
    PHP:
    <table cellSpacing=0 cellpadding=0 width="100%">
      <
    TBODY>
        <
    TR>
          <
    TD style="background-IMAGE: url({THEME}/images/big_menu_1.png); padding-right: 10px; padding-left: 10px; padding-bottom: 5px; padding-top: 5px; border-bottom: #666666 0px solid; height: 30px" colSpan=2>
    <
    b>Добавление Комментария</b>
          </
    TD>
        </
    TR>
        
    <
    TR>
      <
    TD style="padding-right: 10px; padding-left: 10px; padding-bottom: 5px; padding-top: 5px; background-IMAGE: url({THEME}/images/big_menu_2.png)" vAlign=top colSpan=2>
        <
    div style="text-align: justify;">

    <
    table width="100%" class="slink">
      [
    not-logged]
      <
    tr align="left">
        <
    td width="70" height="25"><nobr>Ваше Имя:</nobr></td>
        <
    td height="25"><input style="width:625px" type="text" name="name" class="box" /></td>
      </
    tr>
      <
    tr align="left">
        <
    td width="70" height="25"><nobr>Ваш E-Mail:</nobr></td>
        <
    td height="25"><input style="width:625px" type="text" name="mail" class="box" /></td>
      </
    tr>
      <
    tr align="left">
        <
    td width="70" height="10"></td>
        <
    td width="939" height="10"></td>
      </
    tr>
      [/
    not-logged]
    </
    table>

    <
    table width="100%" border="0" cellspacing="0" cellpadding="0" class="stext">
      <
    tr>
        <
    td colspan="2"><center>[not-wysywyg]{bbcode}[/not-wysywyg][not-wysywyg]<textarea style="width:462px; height:160px;" name="comments" id="comments" class="box" onclick="setNewField(this.name, document.getElementById( 'dle-comments-form' ))" />{text}</textarea>[/not-wysywyg]{wysiwyg}</center><br /></td>
      </
    tr>
    </
    table>

    <
    table width="100%" border="0" cellspacing="0" cellpadding="0" class="stext">
      <
    tr>
    [
    sec_code]
        <
    tr>
             <
    td colspan="2"><center>{sec_code}<br><br><input type="text" name="sec_code" id="sec_code" style="width:120px; height:18px;" class="box" /></center><br /></td>
        </
    tr>
    [/
    sec_code]
      </
    tr>
    </
    table>
    <
    center><input name="submit" type="image" src="{THEME}/images/send.png"></center>
    <
    table width="100%" class="slink">
      <
    tr align="left">
        <
    td width="70" height="0"></td>
        <
    td height="0"></td>
      </
    tr>
    </
    table>

        </
    div>
      </
    TD>
    </
    TR>
    <
    TR>

    <
    TD style="background-IMAGE: url({THEME}/images/big_menu_3_b.png); padding-right: 10px; padding-left: 10px; padding-bottom: 0px; padding-top: 5px; border-bottom: #666666 0px solid; height: 6px" colSpan=2>
    </
    TD>

        </
    TR>
      </
    TBODY>
    </
    table>
     
  2. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.175
    Симпатии:
    2.195
    Знаю этот глюк...
    Мне обычно помогает F5, либо рестарт браузера...

    Очень распостранено в Opera и Mozilla... А вот в IE не наблюдал пока...

    Причину я так понять и не смог...
     
  3. sesharim

    sesharim

    Регистр.:
    4 окт 2006
    Сообщения:
    297
    Симпатии:
    26
    Перезагрузка страницы не помогает !
     
  4. defnur

    defnur Создатель

    Регистр.:
    25 июн 2008
    Сообщения:
    36
    Симпатии:
    0
    попробуй этот файл заменить стандартным, если глюки не исчезнут, то дело вообще не в нем

    а если исчезнут, то сверяй блок за блоком... копипаст - дело не хитрое
     
  5. sesharim

    sesharim

    Регистр.:
    4 окт 2006
    Сообщения:
    297
    Симпатии:
    26
    Нашёл проблему ) Но не совсем понимаю что за ... :)

    Когда удаляю блок {vote}. bbcode и смайлы работают на ура ! Обратно ставлю блок опять не работают ) Что за беда ???

    + щас еще заметил ) Когда блок {vote} С левой стороны шаблона bbcode и смайлы не работают, а когда ставлю на правую сторону шаблона работают ) Вот беда !
     
  6. Shotlandec

    Shotlandec

    Регистр.:
    17 сен 2007
    Сообщения:
    728
    Симпатии:
    162
    у тебя сам шаблон кривой. надо весь шаб смотреть. очень часто при рипе шаблона, многие не верно прописывают <form>, из-за этого начинаются глюки в разных браузерах. это я как пример написал, у тебя может быть ошибка в самом файле vote.tpl , а вот стили здесь скорее всего не причем.
     
  7. sesharim

    sesharim

    Регистр.:
    4 окт 2006
    Сообщения:
    297
    Симпатии:
    26

    Незнаю как рип это или нет ! Но шаб из убогой сборки макоя !
     
  8. Padonok №1

    Padonok №1 Постоялец

    Регистр.:
    20 апр 2007
    Сообщения:
    89
    Симпатии:
    51
    100% ошибка в vote.tpl, проверь!

    у меня такая же ошибка была когда допустил ошибку в выводе топ новостей!
     
    sesharim нравится это.
Статус темы:
Закрыта.