[Помощь] Проблема при обновлении smf

Тема в разделе "Open Source", создана пользователем Akme, 16 окт 2008.

Статус темы:
Закрыта.
Модераторы: Amazko, Aste
  1. Akme

    Akme Творец буковок

    Регистр.:
    8 окт 2008
    Сообщения:
    435
    Симпатии:
    113
    Решение проблемы при обновлении SMF -форума ветки 1.1.X

    Вот решил опытом поделиться в целях экономии времени ближнего :) , поскольку сам времени не мало потратил, пока нашёл решение проблы :(

    Проблема такая:
    При обновлении базы данных форума на следующую версию (в моём случае с 1.1.5 на 1.1.6) специальным скриптом upgrade.php , возникает следующая ошибка:
    Решение нашёл здесь: http://forum.joom.ru/index.php?topic=8719.0
    на радость мне оно оказалось рабочим.
    Кроме того, сделал вывод, что проблема существует в пределах нескольких версий, как минимум, в диапазоне 1.1.2 - 1.1.6 т.е. не исправлена вплоть до самой последней версии smf ветки 1.1.х


    Привожу здесь цитаты из источника выше, которые позволяют решить ситуацию:
    Кроме того, прилагаю два, уже модифицированных, файла, которые требовали изменений для успешного обновления форума :)

    Закачивайте на замену своим и обновляйтесь на здоровье. Однако, следует учесть, что модифицированные файлы относятся к стандартному SMS т.е. без хаков. Если есть хаки, дёргающие эти файлы, то сами модифицируйте свои файлы, как описано выше.
     

    Вложения:

    majordomo и Kurman нравится это.
Статус темы:
Закрыта.