1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

joomla+ стандартный sef + sape

Тема в разделе "Joomla", создана пользователем Dozep, 10 окт 2008.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0, NightHunter
  1. Dozep

    Dozep

    Регистр.:
    5 авг 2008
    Сообщения:
    170
    Симпатии:
    37
    ситуация такая.

    есть жумла 1.0.15 ре эдишн. поставил на нее код сапы. все вроде работает, ссылки на главной от сапы висят, но вот на внутренних страницах они ни как не появляются при включенном стандартном SEF жумлы. если его отключить то ссылки появляются.
    на сапофоруме писали об этой ситуации, кто говорит отключай сеф, другие говорят у них и так работает.

    вообщем что делать? я уже и через вставку кода в шаблон пробывал и через мод_сапе - помогло только отключение сефа, но это опять ждать индексации яши новых страниц
     
  2. Kenny

    Kenny newbie

    Регистр.:
    17 авг 2006
    Сообщения:
    462
    Симпатии:
    150
    Здесь может быть несколько вариантов:
    1. Позволяет ли хостинг использовать mod_rewrite
    2. Переименован ли htaccess.txt в .htaccess
    3. Разрешено ли использование .htaccess
    4. В стандартном ли режиме работает mod_rewrite (для старых версий модуля необходимо редактировать .htaccess на rewrite engine. Я сталкивался с этой проблемой)
    5. Конфигурационные файлы
     
  3. Dozep

    Dozep

    Регистр.:
    5 авг 2008
    Сообщения:
    170
    Симпатии:
    37
    да уже все перебрал и думал что то в хостинге, но тут увидел, что надо код для сапы не такой, который предлагается самой системой, а с дополнением для ЧПУ
    PHP:
    <?php 
         
    if (!defined('_SAPE_USER')){
            
    define('_SAPE_USER''tut_kod_hgdlxfghd;fbhldfbhf;gbhdf;gb5'); 
         }
         require_once(
    $_SERVER['DOCUMENT_ROOT'].'/'._SAPE_USER.'/sape.php'); 
         
    $o['request_uri'] = getenv('REQUEST_URI');
         
    $sape = new SAPE_client($o);
    ?>
    что самое странное, первый раз так сделал с этим кодом - ничего не вышло, а потом еще раз попробывал - вроде работает щас нормально :nezn:
     
Статус темы:
Закрыта.