1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Сложность переделки шаблона 1.5 - 1.0.15

Тема в разделе "Joomla", создана пользователем Лариса, 29 сен 2008.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. Лариса

    Лариса Читатель

    Заблокирован
    Регистр.:
    21 сен 2007
    Сообщения:
    390
    Симпатии:
    128
    Собственно, сабж
    Насколько хлопотно переделать шаблон с одной версии на другую?
    ==
    Дополню: вопрос стоит так- что проще - адаптировать под 1.5. модули галереи, блога, которые конфликтуют с движком, или переделать шаблон под LE 1.015 с версии 1.5?
    Плохо знакома с последней версией, подскажите плз, как сэкономить время?
     
  2. mmka

    mmka ----

    Регистр.:
    23 май 2008
    Сообщения:
    413
    Симпатии:
    201
    Ну вообще при переходе на версию 1.5 все модули, галереи и прочее не обязаны работать даже с включенной поддержкой старых версий. поэтому может быть много глюков, непоняток...
    Поэтому при переходе на 1.5.х версию придется искать похожие модули, компоненты на версию 1.5.х или заказывать переделывать компоненты 1.0.х на 1.5.х
    Также можно заказать переделывание шаблона с 1.0.х на 1.5.х . Это тоже делают.

    А "хлопотно" слово относительно. Для кого это тяжело, а для кого-то нет. Для новичков - тяжело. Для профи - работа как работа.
     
  3. Лариса

    Лариса Читатель

    Заблокирован
    Регистр.:
    21 сен 2007
    Сообщения:
    390
    Симпатии:
    128
    Заказы отпадают сразу =) Это благотвортельный проект.
    Потому заморачиваться неохота.
    Поставим вопрос иначе.
    А что я пробретаю с версией 1.5, если..мне нужна только галерея + блог из компонентов? Посетителей будет мало. производительность не интересует.
    1.0.15 LE против 1.5 - большая ли разница в моем случае?
     
  4. Fansmorgan

    Fansmorgan

    Регистр.:
    30 авг 2007
    Сообщения:
    922
    Симпатии:
    161
    Нет ... разница небольшая !
    Наоборот ... ветка 1.5.х удобнее. Например если необходимо установить компонент, модуль, плагин или шаблон то для этих целей на всё всё только один инсталятор а не для каждого отдельно. Т.е. не как в 1.0 из выпадающего меню выбираешь что заинсталить ... а просто нажимаешь Установить и устанавливаешь что надо !
    Все плюсы я не стану перечислять ... но вообще админка удобнее ... продвинутее в плане того что даже секретарша разберетса что чего и как )))
    Недостатки да ... несовместимость некоторых компонентов и т.д. А так же часто приходитса кодировку переделывать на UTF-8.
    Галлерея и блог это работу сайта не затормозит ...
    В плане шаблона не совсем понял ...
     
  5. Лариса

    Лариса Читатель

    Заблокирован
    Регистр.:
    21 сен 2007
    Сообщения:
    390
    Симпатии:
    128
    объясню еще раз.
    Все компоненты поставились на лавра едишен.
    А шаблон нравится на 1.5.
    но там с компонентами проблема.

    потому и вопрос=)
    переделывать компоненты (блог галерею) под 1.5, или шаблон с 1.5 под 1.0.15LE

    что быстрее?))
     
  6. Fansmorgan

    Fansmorgan

    Регистр.:
    30 авг 2007
    Сообщения:
    922
    Симпатии:
    161
    ясн ...
    ни чего не быстрее ... ни то ни это. Сама наверное знаешь, что переделывать что либо это вообще гемор !
    А в чем собственно проблемма с компонентом блогов и галлереи под 1.5 ? я ставил ... всё прекрасно работает...
    Если не устанавливаетса включаете в плагинах Легаси ...
    Если кракозябры и знаки вопросов - меняете языковые файлы на кодировку UTF-8 ...
    Вобщем лучше компоненты заточить под 1.5 ... ИМХО !

    Ну единственное что добавить хотелось бы ... если же проект будет на J 1.5 и потребуетса доп. функционал, то так и придетса затачивать всё под 1.5. Хотя под неё уже полно всего что пожелаешь !
     
    Лариса нравится это.
  7. mmka

    mmka ----

    Регистр.:
    23 май 2008
    Сообщения:
    413
    Симпатии:
    201
    Если вопрос стоит 1.0.х версия или 1.5.х версия то ИМХО лучше ставить 1.0.хх версию. Ибо там уже все облизано,обкатано и прочее.
    А 1.5 сырая до сих пор. все время выходят релизы безопасности и все время надо обновлять...
    На 1.0.х и компонентов больше и мануалов больше.

    А насчет шаблона: лучше поищите шаблон на 1.0.х ... Я уверен что вы найдете шаблон почти такой же какой вы нашли на 1.5
    Ну в крайнем случае чуток подкорректировать шаблон 1.0.х и приблизить его к "идеальному 1.5"
    Вот и все.
     
    Лариса нравится это.
  8. NeverCrus

    NeverCrus Писатель

    Регистр.:
    27 фев 2008
    Сообщения:
    5
    Симпатии:
    1
    думаю, быстрее будет переделать шаблон, обратите внимание на Joomla Template Kit - набор скриптов для Dreamviewer для облегчения создания шаблонов
     
    Лариса нравится это.
  9. Лариса

    Лариса Читатель

    Заблокирован
    Регистр.:
    21 сен 2007
    Сообщения:
    390
    Симпатии:
    128
    )) понимаете...это по просьбе знакомым. мне не очень-то охота заморачиваться. отсюда и примерки- что проще.
    но для себя я запомню этот совет.
     
Статус темы:
Закрыта.