Помощь [help]после обновлдения ошибки

Тема в разделе "DLE", создана пользователем Mr.Tokio, 13 сен 2008.

Информация :
Актуальная версия DataLife Engine 11.1
( Final Release v.11.1 | Скачать DataLife Engine | Скачать 11.1 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 10.0 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    после перехода на 7.2 с 7.0 у меня посвилось слдующие

    при редактирование групп пользователей и нажатие сохранить выскакивает:
    PHP:
    MySQL Error!
    ------------------------

    The Error returned was:
    Unknown column 'news_sec_code' in 'field list'

    Error Number:
    1054

    UPDATE dle_usergroups set group_name
    ='Журналисты'allow_cats='all'allow_adds='1'cat_add='all'allow_admin='0'allow_addc='1'allow_editc='1'allow_delc='1'edit_allc='0'del_allc='0'moderation='1'allow_all_edit='0'allow_edit='1'allow_pm='1'max_pm='50'max_foto='101'allow_files='1'allow_hide='1'allow_short='1'time_limit='0'rid='3'allow_fixed='0'allow_feed='1'allow_search='1'allow_poll='1'allow_main='1'captcha='0'icon='{THEME}/images/icon_3.gif'allow_modc='0'allow_rating='1'allow_offline='1'allow_image_upload='1'allow_file_upload='0'allow_signature='1'allow_url='1'news_sec_code='0'allow_image='0' WHERE id='3'
    При редактирование отдельного персонажа , а точней при переносе его в другую группу выскакивает вот это:

    PHP:
    MySQL Error!
    ------------------------

    The Error returned was:
    Unknown column 'restricted' in 'field list'

    Error Number:
    1054 

    UPDATE dle_users set user_group
    ='1'banned=''icq='номер аськи'land='Украина'info=''signature=''email='ну тут емайл'fullname='Илья'time_limit=''xfields=''restricted='0'restricted_days='0'restricted_date='' WHERE user_id='1247'
     
  2. potehi

    potehi Создатель

    Регистр.:
    9 авг 2008
    Сообщения:
    32
    Симпатии:
    22
    Похоже обновление базы не выполнено!

    Ты запускал upgrade/index.php ???
     
  3. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    запускал я это обновлен.

    запустил повторно..тоже самое....
     
  4. potehi

    potehi Создатель

    Регистр.:
    9 авг 2008
    Сообщения:
    32
    Симпатии:
    22
    В файле \engine\data\config.php

    Найди

    'version_id' => "7.2",


    Замени на

    'version_id' => "7.0",

    И выполни повторное обновление. Просмотрел запросы, которые выполняются при обовлении. Они не выполнены 100%.
     
  5. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    Сделал как ты писал...ничего не изменилось((((((
    кто еще какиенибудь методы которые могут помочь??
     
  6. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    все перелазил..не могу найти...никто не знает???
     
  7. glam

    glam

    Регистр.:
    12 апр 2007
    Сообщения:
    734
    Симпатии:
    217
    Jemsbond не знаешь - хоть бы промолчал! Ошибка пишет что данная колонка news_sec_code не найдена, как всегда скосячил файл обновления, очень часто это замечаю при переходе с 7 на 7.2, хотя в чем причина до сих пор остаётся загадкой
     
  8. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    сделал откат на 7.0 попробовал сделать еще раз обновление...блин я уже не знаю что делать..я не могу нормально отредактировать группы и пользователей.....
     
  9. kandasoft

    kandasoft Читатель

    Заблокирован
    Регистр.:
    17 окт 2007
    Сообщения:
    259
    Симпатии:
    143
    Если есть бекап базы перед обновлением, то можете попробовать поставить старую версию скрипт (на которой делали бекап) и попробовать обновиться до актуальной версии снова.

    Есть еще выход:
    Просто добавить несколько колонок, которых у Вас нет, в данном случае: 'restricted' и 'news_sec_code'
    Добавьте их напрямую через phpMyAdmin...

    Думаю, что Вы умеете работать с phpMyAdmin, если нет, то отпишитесь в теме, я подробно распишу, что именно нужно сделать.
     
  10. Mr.Tokio

    Mr.Tokio

    Регистр.:
    17 дек 2007
    Сообщения:
    282
    Симпатии:
    44
    Давай буду не против если подробно распишешь....
     
Статус темы:
Закрыта.