Помощь Проблема с картинками

Тема в разделе "DLE", создана пользователем erosfera, 31 дек 2006.

Информация :
Актуальная версия DataLife Engine 11.2
( Final Release v.11.2 | Скачать DataLife Engine | Скачать 11.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. erosfera

    erosfera Прохожие

    Версия 5.2 , для пробы закачал две картинки в новости все работает, добавляю еще 3 картинки и штук 20 текстовых новостей, соответственно первые ушли на 3 страницу, но отображаются только первые 2 картинки которые были добавлены первыми соответственно их путь в свойствах указан как например
    uploads/alie1.jpg
    следующие картинки уже не отображаются смотрю в свойствах их путь они видны как /category/homeerotik/uploads/grudi1.jpg, такой категории, точнее директории как /category/homeerotik нет как таковой на сервере, но кажется я ничего не менял в настройках , если меняю в отображение новостей порядок с возростания на убывание то соответственно картинкиснова видны, так как они находятся на главной, точнее на первой странице, может кто встречал такую проблему отзовитесь.
     
  2. Jerry

    Jerry тот самый Учиха

    Регистр.:
    16 апр 2006
    Сообщения:
    1.226
    Симпатии:
    489
    покапайтесь в шаблоне и попробуйте с нуля дле установить посмотреть как оно поведёт себя
     
  3. m1kola

    m1kola

    Регистр.:
    13 дек 2006
    Сообщения:
    221
    Симпатии:
    55
    erosfera, я кажеться знаю в чём проблема...
    Сначала поясню насчёт деректории /category/homeerotik/ всё правельно.... это у вас включен ЧПУ... Ведь же у новости из категории допустим "Эротика" у которой "Альтернативное имя" homeerotik как пишеться УРЛ? правелно... http://sait.ru/category/homeerotik/blandinka.html ... ну это пример...

    Теперь основная проблема...
    Залезьте в админку посмотрите какой путь указан в настройках системы (Домашняя страница сайта:) ... Скорее всего он воообще НЕ указан... Потому и получаются такие косяки... Видимо вы первые 2 картинки (которые отображаются) запостили до того как стёрли УРЛ в настройках... Вот теперь картинки у вас и добавляются в редакторе в виде... допустим... [img=left]uploads/posts/1170800661_m1kola.gif[/img]... обратите внимание, что они должны добавляться в виде [img=left]http://sait.ru/uploads/posts/1170800661_m1kola.gif[/img]

    Вобщем если я правельно понял проблему, и если проблема в том, что нет урла в настройках, то поставьте его....Если проблема в этом, то я уверен, что косяки бду не только с картинками, но и ссылками (кроме главной, на главной будет всё ок.), но если с сылками допустим в модулях (допустим топ ньюсов) можно непариться, т.к когда вы поставите урл в настройки, то ссылки поменяются.... А вот с изображениями придётся повазиться... Все изображения которые вы звгрузили огда у вас небыло в настойках урла придётся менять.. т.е. редактировать новости...
    допустим в [img=left]uploads/posts/1170800661_m1kola.gif[/img] предётся подставлять перед upload/.... урл http://sait.ru/, что бы в конце концов получилось [img=left]http://sait.ru/uploads/posts/1170800661_m1kola.gif[/img] ну или же перед upload/... поставить просто слэш.... и всё будет ок...

    ЗЫ: Я пытался помочь.... Но я пьян сейчас... если не поняли то пишите сдесь....
    Так же прошу простить если не втему... .если я не понял проблемы...

    И прошу отписать если проблема была именно в отсутствии УРЛа в настройках...
     
  4. erosfera

    erosfera Прохожие

    Кажется понял спасибо, но проверю потом отвечу
     
  5. m1kola

    m1kola

    Регистр.:
    13 дек 2006
    Сообщения:
    221
    Симпатии:
    55
    Ок. жду ответа...
    // Я вот сидел потом сам разбирал :)
    // когда разобрал :) потестил на локалке... Если я
    // правельно понял то что было спрошено, то должно
    // работать ;)
     
    vik1 нравится это.
  6. vik1

    vik1 Создатель

    Регистр.:
    3 окт 2006
    Сообщения:
    25
    Симпатии:
    0
    кстати у меня заработало,блин бился долго
     
  7. m1kola

    m1kola

    Регистр.:
    13 дек 2006
    Сообщения:
    221
    Симпатии:
    55
    erosfera, а у тебя как дела? помогло?
     
  8. Solonik

    Solonik Прохожие

    У меня кстати хуже фигня была, работало все нормально потом резко все новости пропали, хотя в админке они есть, нажимаю повторно редактировать и отправить, а они на главной не появляются!!!
     
Статус темы:
Закрыта.