[Помогите] Проблема с html кодом

Тема в разделе "Wordpress", создана пользователем diab0583, 4 июл 2008.

Статус темы:
Закрыта.
Модераторы: DzSoft, Sorcus
  1. diab0583

    diab0583

    Регистр.:
    9 июл 2007
    Сообщения:
    199
    Симпатии:
    25
    Решил проверить html код блога на WP
    Валидатор html выдал мне
    ….css" type="text/css" media="screen" />
    Я как понял это из-за пробела между " и /
    Поясните пожалуйста в чём дело.;)
     
  2. Simpson

    Simpson

    Регистр.:
    22 июл 2007
    Сообщения:
    373
    Симпатии:
    36
    это, вроде как, сокращенная форма закрывающего тэга - попробуй сделать так:
    media="screen"></style>
     
  3. надо

    надо Прохожие

    Это из-за / который есть чуть ли не во всех ХТМЛ шаблонах чуть ли не всех форумных движков. Ничего страшного тут нет.

    Можешь убрать, можешь оставить.
     
  4. Yozik

    Yozik

    Регистр.:
    5 дек 2007
    Сообщения:
    238
    Симпатии:
    65
    Вообще-то любой валидатор выдаёт подсказки. По теме - скорее всего валидатор кроме этого тэга увидел ещё один закрывающий для этой строки. Т.е. либо ищи второй закрывающий тэг, который твой валидатор скорее всего тоже выделил, либо удали слэш в твоём примере, и проверь ещё раз.
     
  5. надо

    надо Прохожие

    з.ы я имел ввиду именно эту комбинацию: <bla bla bla " " />
     
  6. Смоленский

    Смоленский

    Регистр.:
    2 июл 2008
    Сообщения:
    248
    Симпатии:
    87
    Данная проблема возникает из-за редакторов которые могут писать символы в разных кодировках, например Notepad++ и виндовый блокнот. Если пользуетесь PSPad откройте файл header.php и сохраните его в кодировке UTF-8, проблема исчезнет.

    По теме можете поискать информацию по BOM - Byte Order Mark.
     
Статус темы:
Закрыта.