[Помогите] Проблема с кодировкой

Тема в разделе "Wordpress", создана пользователем rim89, 28 июн 2008.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. rim89

    rim89 Постоялец

    Регистр.:
    7 апр 2008
    Сообщения:
    87
    Симпатии:
    5
    Есть блог http://s-live.org/, стоит тема перевел все в UTF-8, дописал в .htaccess AddDefaultCharset utf-8 , но тема всеравно криво отображается, в чем может быть проблема
     
  2. sw04

    sw04 seoplayer

    Регистр.:
    1 дек 2007
    Сообщения:
    601
    Симпатии:
    193
    на ff и ie6 всё хорошо отображается.
    приведите скрин, пожалуйста...
     
    rim89 нравится это.
  3. rim89

    rim89 Постоялец

    Регистр.:
    7 апр 2008
    Сообщения:
    87
    Симпатии:
    5
  4. il_vincitore

    il_vincitore Создатель

    Регистр.:
    15 июн 2008
    Сообщения:
    20
    Симпатии:
    1
    У Вас в самом коде темы наверняка пописано в кодировке 1251, пишите мне в котакты... Помогу безвозмездно (с такой проблемой сталкивался, решил).
     
    rim89 нравится это.
  5. sbd3

    sbd3 Писатель

    Регистр.:
    10 июн 2008
    Сообщения:
    6
    Симпатии:
    1
    Проблема в самой теме. Какая тема, откуда скачал, сообщи, а я проверю.
     
    rim89 нравится это.
  6. rim89

    rim89 Постоялец

    Регистр.:
    7 апр 2008
    Сообщения:
    87
    Симпатии:
    5
    Возможно это Notpade++ заглчил, хотя маловероятно, за завтра заново переведу, может пропадет, если нет, то выложу тему на расчленение
     
  7. zizop

    zizop Прохожие

    Попробуй, вот это:

    Код:
      mysql_query ("set character_set_client='cp1251'");
      mysql_query ("set character_set_results='cp1251'");
      mysql_query ("set collation_connection='cp1251_general_ci'"); 
    
     
  8. rim89

    rim89 Постоялец

    Регистр.:
    7 апр 2008
    Сообщения:
    87
    Симпатии:
    5
    Как я понял, это конвертирование SQL базы, а смысл, когда контент отображается правило, баг с измененными словами в шаблоне темы
     
  9. rim89

    rim89 Постоялец

    Регистр.:
    7 апр 2008
    Сообщения:
    87
    Симпатии:
    5
    Итак, проблема вроде решена..Всем кто откликнулся "+"
    Первоначально переводил тему Notpade++, переконвертил файлы и перевел... вот и получил проблема.
    Сегодня переводил PSPad, первел и залил, вроде все ОК
     
  10. Sjajna

    Sjajna Создатель

    Регистр.:
    3 мар 2008
    Сообщения:
    10
    Симпатии:
    1
    у меня прописано:

    CharsetDisable On
    CharsetDefault UTF-8
    CharsetSourceEnc UTF-8

    И все работает.
     
Статус темы:
Закрыта.