[help] как вы обовляете dle c ранних версий на новые

Тема в разделе "DLE", создана пользователем gruppastimul, 27 май 2008.

Информация :
Актуальная версия DataLife Engine 11.3
( Final Release v.11.3 | Скачать DataLife Engine | Скачать 11.3 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.2 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. gruppastimul

    gruppastimul Ваш

    Регистр.:
    22 окт 2006
    Сообщения:
    802
    Симпатии:
    130
    как безболезненно и без установления с нуля всех модулей обновить сайт например на 5 ленейке до 7 или с 6 до 7.

    тоесть сайт сделан на 5 версии скрипта и напичкан модулями , а хочется перейти на 7, но модули не устанавливать, а обновить файлы - отмержить их. Может кто поделиться техникой. Кто как может быть мержит файлы или мержил.


     
  2. JC

    JC Бог пикселей

    Регистр.:
    4 янв 2008
    Сообщения:
    303
    Симпатии:
    401
    Так а смысл если модули с 5ой версии не будут идти на 7.
     
  3. gruppastimul

    gruppastimul Ваш

    Регистр.:
    22 окт 2006
    Сообщения:
    802
    Симпатии:
    130
    ну или 6той )))
     
  4. [iq]

    [iq]

    Регистр.:
    17 июл 2007
    Сообщения:
    201
    Симпатии:
    44
    -=JC=-, почему не будут идти? (единственное проблема будет с классами наверное и все, просто некоторые переписаны же).

    gruppastimul, а так с 5.3 на 6.5 тупо переставлял моды и усе... единственное, что мне приходит на данный момент в голову: это скопировать куски кода из index,engine,options где идут исправления в одних места в каждом моде(почти). Но это лишь чуть поможет при переносе, а так придется ставить все на 7.0
    ЗЫ вот если бы все изменения вносились куда-нибудь и запоминались, то тогда была бы возможность проводить апгрейд без установки с нуля всего.
     
  5. JC

    JC Бог пикселей

    Регистр.:
    4 янв 2008
    Сообщения:
    303
    Симпатии:
    401
    Потому что много чего переделано в самом движке по сравнению с 5 и 7 линейке...Есть модули которые идут с 5 линейки на 7, но их очень мало, и то они сам движое не очень затрагивают...
     
  6. SOCRAT

    SOCRAT

    Регистр.:
    6 июн 2006
    Сообщения:
    275
    Симпатии:
    54
    Сравнивай файлы, ищи отличия и меняй..

    По объему предстоящей работы, имхо, проще модули заново поставить, ибо задолбаешься вручную апдейтить..
     
  7. igramnet

    igramnet

    Регистр.:
    7 авг 2007
    Сообщения:
    281
    Симпатии:
    35
    Я обновлял 5,7 до 7,0 по инструкции. Заменил шаблоны, добавил теги, обновил модули ну и кнопка обновить в движке. Багов не было. Главное делать бекапы и всё по инструкции.
     
  8. pozerovnet

    pozerovnet

    Регистр.:
    31 янв 2008
    Сообщения:
    400
    Симпатии:
    11
    У меня точно такая же проблема, как у ТС, парюсь с ней очень давно :(
     
  9. gentoouser

    gentoouser

    Регистр.:
    8 окт 2007
    Сообщения:
    187
    Симпатии:
    63
    сделай бэкап движка и базы.
    замени все файлы движка новыми.
    обнови базу движка через upgrade/index.html
    обнови шаблон, если он отличается от стандартного
    проделай изменения в файлах движка согласно с инструкциями установки модулей.
    при возникновении косяков, придётся править модули.

    з.ы. при обновлении с такой старой версии, я бы посоветовал всё ставить с 0.
    единственное что тебе нужно взять из движка, это кусок подключения файлов в index.php, массив опций из /inc/options.php ну и ещё набор case'ов из engine.php
     
  10. dos03

    dos03 -----

    Регистр.:
    9 мар 2007
    Сообщения:
    871
    Симпатии:
    428
    Со многими модами сейчас идет файл инсталла. Никто не пробовал собрать один инсталяционный файл, чтобы при обновлении разом сделать все нужные изменения ;)
     
Статус темы:
Закрыта.