[Помогите] Проблема при переезде

Тема в разделе "Wordpress", создана пользователем Sammy, 22 май 2008.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. Sammy

    Sammy

    Регистр.:
    30 янв 2007
    Сообщения:
    222
    Симпатии:
    19
    Переехал на новый сервер. Перенесли вордпресс. Все нормально отображается(по русски:( новости, статьи, но админка, заголовки виджетов, плагины - на английском языке. ничего в настройках не менялось.
    в чем может быть проблема?
     
  2. nik0tin

    nik0tin

    Регистр.:
    29 авг 2007
    Сообщения:
    320
    Симпатии:
    56
    Проверь правильное написание языковых файлов там должно быть ru_RU.po тоесть второе RU должно быть написано с большой буквы, ну и с расширением *.mo проверь. А у тебя скорей всего ru_ru.po написано. Это ftp - клиент порезал так имя файла.
     
  3. Sammy

    Sammy

    Регистр.:
    30 янв 2007
    Сообщения:
    222
    Симпатии:
    19
    nik0tin
    файлы *.mo
    проверил всякие настройки=было как раньше, а язык-английский
     
  4. nik0tin

    nik0tin

    Регистр.:
    29 авг 2007
    Сообщения:
    320
    Симпатии:
    56
    \wp-includes\languages в этой папке находятся языковые файлы ru_RU.mo и ru_RU.po если называются они как я написал, то должно все работать.
     
  5. Sammy

    Sammy

    Регистр.:
    30 янв 2007
    Сообщения:
    222
    Симпатии:
    19
    есть такие файлы, но не работает!:(
     
  6. nik0tin

    nik0tin

    Регистр.:
    29 авг 2007
    Сообщения:
    320
    Симпатии:
    56
    Жесть. WP какой версии? Что еще есть в этой папке? Скрин сделай.
     
  7. Sammy

    Sammy

    Регистр.:
    30 янв 2007
    Сообщения:
    222
    Симпатии:
    19
    wp 2.3.1 все папки, все файлы на месте - сравнил.
    может с правами на файлы что то?
     
  8. nik0tin

    nik0tin

    Регистр.:
    29 авг 2007
    Сообщения:
    320
    Симпатии:
    56
    У меня работает с правами 755 на все папки 644 на все файлы но у каждого хостера по-разному.
     
  9. Sammy

    Sammy

    Регистр.:
    30 янв 2007
    Сообщения:
    222
    Симпатии:
    19
    Решил наконец проблему:
    Если вы ставили вордпресс 2.3.х на сервер с php4, а потом перенесли на серв с рнр5 то необходимо поставить патч для нормально отображения русского
     
  10. genarator2003

    genarator2003 Постоялец

    Регистр.:
    23 авг 2007
    Сообщения:
    113
    Симпатии:
    8
    У меня тоже проблемы с переездом я набил WP базу в денвере под виндой всё в UTF-8 стоит MYSQL4.1
    Бэкаплю базу и заливаю на хост(NIC.ru) через phpmyadmin везде иероглифы ((
    Если скормить весь sql файл на вкладке sql то всё норм но русский текст превращается в что-то типа:
    Код:
    & #1057;& #1074;& #1077;& #1088;& #1083;& #1072; & #1087;& #1086; & #1076;& #1077;& #1088;& #1077;& #1074;& #1091;
    это в сырце html
     
Статус темы:
Закрыта.