Не работает mod_rewrite

Тема в разделе "Mod Rewrite / htaccess / ЧПУ", создана пользователем mihan, 6 дек 2007.

Статус темы:
Закрыта.
  1. mihan

    mihan Постоялец

    Регистр.:
    11 мар 2007
    Сообщения:
    65
    Симпатии:
    20
    В общем установил Apache 2.0.61 на Линуксе, прикрутил php, мускуль, все как полагается. Установил для теста движек DLE и тут выяснилось, что mod_rewrite не пашет. Т.е нажимаю на новость и выскакивает 404 ошибка...
    С выключенным ЧПУ все нормально.

    Апач конфигурировал так:
    Подскажите плиз в чем может быть проблема :bc:
     
  2. terkin

    terkin

    Регистр.:
    9 дек 2006
    Сообщения:
    513
    Симпатии:
    162
    Ты уверен что апач исполняет файлы .htaccess ? если нет то поставь AllowOverride ALL в настройках хоста
     
  3. mihan

    mihan Постоялец

    Регистр.:
    11 мар 2007
    Сообщения:
    65
    Симпатии:
    20
    Ээээ...а где это проверить и как исправить? Извиняюсь за тупость конечно :ah:
     
  4. terkin

    terkin

    Регистр.:
    9 дек 2006
    Сообщения:
    513
    Симпатии:
    162
    ну вообще для проверки пашет .htaccess или нет напиши в нём deny all, и попробуй зайти если напишет Forbidden То значит пашет твой .htaccess а если нет то лезь в /etc/apache2/sites-enabled далее нужный конфиг или может он у тебя единственный, ищи нужный сайт AllowOverride NONE заменяй на AllowOverride ALL
     
    vestal и mihan нравится это.
  5. mihan

    mihan Постоялец

    Регистр.:
    11 мар 2007
    Сообщения:
    65
    Симпатии:
    20
    Вот это и как раз помогло! :yahoo:
     
Статус темы:
Закрыта.