Инфо Прекращение поддержки Magento 1 в июне 2020. Обновлений больше не будет!

Тема в разделе "Magento", создана пользователем artmouse, 26 июн 2020.

XEvil 4.0 Релиз Состоялся!
Метки:
?

Планируете ли Вы перевод своих сайтов на Magento 2

Это голосование будет закрыто 23 дек 2020 в 22:37.
  1. Останусь на Magento 1

    55,6%
  2. Планирую переход на Magento 2

    11,1%
  3. Уже мигрировал на Magento 2

    22,2%
  4. Перешёл на другой движок/CMS

    0 голосов
    0,0%
  5. Что вообще происходит???

    11,1%
Модераторы: artmouse, Violent
  1. artmouse

    artmouse ★ ★ ★ ★ ★

    Moderator
    Регистр.:
    16 июн 2007
    Сообщения:
    390
    Симпатии:
    890
    EXdgTXLUcAA46Vz.jpg

    Magento 1 больше не будет обновляться
    С момента выпуска Magento 2 в ноябре 2015 года было много предположений относительно прекращения поддержки предыдущей версии. Ходили слухи о том, что поддержка Magento 1 будет завершена к ноябрю 2018 года, но отсутствие какого-либо официального объявления привело к массовым опасениям для тех, кто все еще работает в этой версии. Наконец-то, Magento официально заявила, что они будут поддерживать более старую версию до июня 2020 года.

    Из официального заявления: Magento Community Edition с открытым исходным кодом будет получать исправления до июня 2020 года, чтобы гарантировать безопасность этих сайтов. Это значит, что после этого срока, ваш сайт будет потенциально уязвим.

    Что значит окончание поддержки моей версии CMS?
    Для CMS систем, как и другого ПО, есть такое понятие как End of Life (EOL). Если дословно — «окончание жизни системы». Это момент, когда более старая версия перестает поддерживаться компанией или сообществом, которая ее создала, и все усилия будут сосредоточены на текущей и будущей версиях. Обычно, о окончании поддержки говорят заранее, чтобы было время перестроить свой продукт на новую версию системы.

    В данном случае, если вы еще не переехали на Magento 2, советуем спланировать переезд на новую версию.

    источник
     
  2. h3xmstr

    h3xmstr Писатель

    Регистр.:
    12 окт 2018
    Сообщения:
    6
    Симпатии:
    5
    Найдется много магазинов, для которых перенос на M2 нерентабелен. Например из-за большого количество полностью кастомных модулей или специфичных интеграций.

    Для таких пользователей может быть полезен проект OpenMage: Magento LTS, который будет неофициально поддерживать Magento 1.x после "официального EOL"
    https://github.com/OpenMage/magento-lts

    Magento - Long Term Support
    This repository is the home of an unofficial community-driven project. It's goal is to be a dependable alternative to the Magento CE official releases which integrates improvements directly from the community while maintaining a high level of backwards compatibility to the official releases.

    Проблемы совместимости с новыми версиями PHP и MySQL можно решить, разместив проект в контейнерах Docker, "заморозив" таким образом версии серверного ПО (правда, и обновлений безопасности не будет). Также потребуется хостинг, где возможно использование Docker или непосредственно самих контейнеров.
     
    Nick7777777, agypten, lawko и ещё 1-му нравится это.
  3. artmouse

    artmouse ★ ★ ★ ★ ★

    Moderator
    Регистр.:
    16 июн 2007
    Сообщения:
    390
    Симпатии:
    890
    Adobe, Mastercard и Visa призвали отказаться от использования старых версий Magento

    Компании Visa, Mastercard и Adobe призвали владельцев online-магазинов обновить свои платформы Magento, поскольку 30 июня версия Magento 1.x достигнет срока окончания поддержки (End of Life, EOL). Магазины, не обновившиеся до последней ветки 2.x и все еще использующие версии Magento 1.x, станут уязвимыми к атакам киберпреступников, сообщило издание ZDNet.

    По словам команды специалистов Mastercard Account Data Compromise (ADC), ответственной за расследование киберинцидентов с данными платежных карт, в последние годы участились случаи web-скимминга. Большинство из них были связаны с web-сайтами, использующими старые версии программного обеспечения Magento. По данным Mastercard, 77% компаний, пострадавших в результате подобных инцидентов, не соблюдали норму стандарта безопасности данных индустрии платежных карт (PCI DSS), требующую использования современного программного обеспечения.

    Как и Mastercard, Visa также предупредила владельцев магазинов, чтобы они обновились до последней версии Magento 2.3.x с целью избежать потенциальных атак.

    22 июня компания Adobe, владеющая платформой Magento, выпустила последние обновления безопасности для ветки Magento 1.x.

    По данным ИБ-фирмы SanSec, в настоящее время около 110 тыс. магазинов по-прежнему используют ветку Magento 1.x и только 37,5 тыс. магазинов обновились до новых версий.
     
  4. KaiSer77

    KaiSer77 Постоялец

    Регистр.:
    21 июл 2013
    Сообщения:
    128
    Симпатии:
    60
    Вышла новая версия 20.0.0 Magento Open LTS. Версия 1.9.4.4 в этом проекте теперь называется 19.4.4

    Я пока не разобрался, почему Magento Open LTS не накатывали 1.9.4.5, будьте осторожны эта версия меняет в базе данных все пароли пользователей и админов, ее просто так назад не закатить. Возможно стоит после 1.9.4.4 переходить на 19.4.4 !!!
     
    Nick7777777 нравится это.