Модуль Модуль "Мультивалютные товары" null без стучалки

Тема в разделе "Opencart", создана пользователем Denzy, 29 фев 2020.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
  1. Denzy

    Denzy Постоялец

    Регистр.:
    29 июл 2016
    Сообщения:
    57
    Симпатии:
    50
    https://opencartforum.com/files/file/2170-modul-multivalyutnye-tovary/
    Попался мне такой модуль под версию 2.3, стучалку удалил


    Вдруг кому пригодится. Если достану под другие версии - выложу
     
    TyT, Protector и RedDeviLL нравится это.
  2. Protector

    Protector

    Регистр.:
    17 ноя 2013
    Сообщения:
    178
    Симпатии:
    20
    Давно не смотрел Opencart, поэтому такой вопрос - с помощью этого модуля можно "прикрепить" к каждой валюте отдельную платёжную систему ? Например к рублю яндекс деньги и wmr, к доллару wmz и paypal, и т.д. ?
    И ещё вопрос не по теме - движок вообще обновляется ? Можно рассчитывать хотя бы на базовые обновления, например при изменении версии php и mysql ?
     
  3. Denzy

    Denzy Постоялец

    Регистр.:
    29 июл 2016
    Сообщения:
    57
    Симпатии:
    50
    1)Нет. Модуль нужен для того что бы можно было завивать цену товара в различных валютах. Например.... Есть 3 поставщика, 1 даёт цены только в евро, 2 в долларах, 3 в рублях. С помощью модуля, цены забиваются в той валюте, в которой дал поставщик, конвертируется и выводится в той валюте, которая указана по умолчанию.
    2) Движок не обновляется самостоятельно, только вручную. При создании магазина, движок изменяется индивидуально. Часть изменений происходит через модификаторы (OCMOD), а часть изменяет/перезаписывает файлы. Это касается не только движка, но и шаблона.
    3) Смотря какую ветку вы выберите. Есть устаревшая ветка 1.5, есть ветка 2.х ( 2.0, 2.1,2.2,2.3) и 3.х.
    Ветка 1.5 морально устарела, и работает только на php 5.2-5.5 из коробки. Можно с костылями завести на php 5.6 и php 7.х.
    Проблема в переходе на другие версии php из за платных модулей/шаблонов, зашифрованных в Ioncube. Файлы шифруются под определённую версию php, и на других версиях php не работают.
    Шифруются модули, что бы их не тырили.
    По поводу вашего вопроса, по идее видел недавно модуль, но не помню названия
     
    Protector нравится это.
  4. Protector

    Protector

    Регистр.:
    17 ноя 2013
    Сообщения:
    178
    Симпатии:
    20
    Ну, модули и плагины с IonCube я никогда не использую, ещё вопрос что там зашифровано. Просто лет через 10 может появится php 35, а версия Opencart как была 3.0.3.2, так ею и осталась. У Wordpress такой проблемы нету, он регулярно обновляется.
    Если найдёте такой модуль бесплатный или ломанный отпишите пожалуйста в ЛС, в прошлый раз (где то полгода назад изучал движок) мне именно его не хватило для установки двухвалютности на моей сборке.