Инфо Prestashop 1.7.6.x

Тема в разделе "PrestaShop", создана пользователем _sashok, 29 апр 2019.

Метки:
Информация :
Приветствую гость, обрати внимание! Темы которые закреплены в разделах, в скором времени будут откреплены. Правила раздела PrestaShop

(Не актуальные темы) Каталоги:Модули PrestaShop 1.7Модули PrestaShop 1.5 - 1.6Шаблоны PrestaShop 1.7Шаблоны PrestaShop 1.5 - 1.6
(Не актуальные темы) Поиск / Запросы:Модули PrestaShop 1.7Модули PrestaShop 1.5 - 1.6Шаблоны PrestaShop 1.7Шаблоны PrestaShop 1.5 - 1.6
Полезная информация:Поддержка и помощь c PrestaShopУбираем ПрестаТраст, стучалки и прочую рекламуСовместные покупки модулей и шаблоновПеревод Prestashop и модулей
Модераторы: trace
  1. protoproto

    protoproto Постоялец

    Регистр.:
    14 янв 2018
    Сообщения:
    51
    Симпатии:
    26
    Если кто аглицкой грамоте не обучен то перевожу "Not supported" - не поддерживается. А рекомендация это там где птичка стоит в таблице на зеленом фоне.
    И не надо считать себя умнее разрабов Престы и изобретать велосипед.
     
  2. _sashok

    _sashok PrestaShop Expert

    Регистр.:
    15 июл 2011
    Сообщения:
    2.145
    Симпатии:
    3.552

    спокойно: перфекционизм лечится реализмом! :)

    разработчикам ядра престы главное "недобздеть", чтобы продать больше стабильности их модулей

    почитайте разницу между php 7.3 и 7.2, и увидите, что там в престе 1.7 буквально пару моментов нужно учесть/подправить, и ваш проект будет "летать", например:

    Prestashop 1.7.6 на CentOS 7.7 ( nginx 1.16 + php 7.3 + mysql 5.7 )
    https://developers.google.com/speed/pagespeed/insights/?url=https://nasosvdom.com.ua
    https://developers.google.com/speed/pagespeed/insights/?url=https://denta-ua.com
    https://developers.google.com/speed/pagespeed/insights/?url=https://akvitens.com.ua
     
    Последнее редактирование: 24 сен 2019
    dpdp, Belena27089, savvato и ещё 1-му нравится это.
  3. protoproto

    protoproto Постоялец

    Регистр.:
    14 янв 2018
    Сообщения:
    51
    Симпатии:
    26
    повторяю не надо изобретать велосипед, нужно всегда придерживаться рекомендаций производителя.
    И править ее тоже не надо, а то потом автоапдейт не работает и глюки косяками.
     
  4. savvato

    savvato Кодер

    Регистр.:
    3 янв 2012
    Сообщения:
    491
    Симпатии:
    457
    позвольте не согласиться. Смотря как править.
     
    evgenij.sobolev нравится это.
  5. protoproto

    protoproto Постоялец

    Регистр.:
    14 янв 2018
    Сообщения:
    51
    Симпатии:
    26
    чем меньше тем лучше что бы Преста не переставала быть Престой
     
  6. ВасилийК

    ВасилийК Постоялец

    Регистр.:
    22 авг 2017
    Сообщения:
    63
    Симпатии:
    55

    Всем доброго дня!

    В итоге... обновил MySQL до версии 5.7, обновил снова. Ошибок стало меньше (возможно связано не с этим). Ошибки выдавали модули google advanced sitemap и robokassa. После удаления ошибки пропали.
     
    _sashok нравится это.
  7. yuazakharov

    yuazakharov

    Регистр.:
    22 янв 2013
    Сообщения:
    297
    Симпатии:
    144
    PHP 5.6 + Apache 2.2 + MySQL 5.0 + Debian 7.

    Presta 1.7.6.1 при установке выдает ошибку:
    1: HTTP 502 - error -
    Таблицы в базу создаются.

    Раньше сюда 1.6 без проблем ставился, а тут такая беда

    [​IMG] [​IMG]

    В логах какой то непонятный путь запрашивает
    File does not exist: /home/admin/web/ouykt.ru/public_html/2019

    ls: cannot access /home/admin/web/ouykt.ru/public_html/2019: No such file or directory
     
    Последнее редактирование: 15 ноя 2019
  8. Jarhead

    Jarhead

    Регистр.:
    17 июн 2011
    Сообщения:
    406
    Симпатии:
    153
    Касательно версий PHP, по своему опыту наблюдал проблемы работы prestashop 1.7.5.1 - 1.7.6.1 на PHP 7.2 при включенном модуле Memcached в самых неожиданных местах типа авторизации в админку или чистки кеша на странице производительности, может и еще где ошибки есть, не изучал, на версии php 7.1 все ок.

    И самое главное то что Вы измените версию PHP на 7.2 или 7.3 это вообще не означает что у Вас сайт будет работать быстрее, надежнее или как то лучше. Сначала почитайте об разнице между 7.1 и 7.2-73 потом прикиньте как именно это применимо может быть для prestashop, а после изучите применяется ли где новшества этих версий в prestashop. Если на официальном сайте поддержка этих версий не заявлена, то и ставить эту версию PHP не имеет абсолютно не какого смысла, все что Вы получите это скорее всего возможные ошибки.
     
    Kolfg и _sashok нравится это.
  9. Jarhead

    Jarhead

    Регистр.:
    17 июн 2011
    Сообщения:
    406
    Симпатии:
    153
    Mysql 5.0 вот прям так и написано? Посмотрите что в php error логе.
     
  10. yuazakharov

    yuazakharov

    Регистр.:
    22 янв 2013
    Сообщения:
    297
    Симпатии:
    144
    В странице phpinfo версия так и написана