Node.JS - помогите сделать первые шаги

Тема в разделе "JavaScript", создана пользователем Menro, 17 сен 2017.

Модераторы: ZiX
  1. Menro

    Menro web, seo, email, hack

    Регистр.:
    27 янв 2008
    Сообщения:
    626
    Симпатии:
    125
    Всем привет!
    Столкнулся с задачей - отредактировать существующий шаблон сайта, точнее его стили.
    Вместо привычных мне CSS, вижу SCSS.
    Добрался до того, что на серваке установил Node.js, и возникла проблема с Gulp (это уже в доках разработчика темы нашёл).
    Перехожу в папку с файлами командой и запускаю gulp watch.
    Как я понял, после запуска, всё, что я редактирую в этих файлах, должно компилироваться автоматически, но при запуске у меня выходят ошибки, я вообще не пойму что-то от меня хотят..

    Код:
    npm ERR! Error: No compatible version found: deprecated@'^0.0.1'
    npm ERR! Valid install targets:
    npm ERR! ["0.0.1","0.0.2"]
    npm ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.j                               s:685:10)
    npm ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:607:10
    npm ERR!     at saved (/usr/local/lib/node_modules/npm/node_modules/npm-registry                               -client/lib/get.js:138:7)
    npm ERR!     at Object.oncomplete (fs.js:107:15)
    npm ERR! If you need help, you may report this log at:
    npm ERR!     <http://github.com/isaacs/npm/issues>
    npm ERR! or email it to:
    npm ERR!     <npm-@googlegroups.com>
    
    npm ERR! System Linux 3.10.0-514.16.1.el7.x86_64
    npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "gulp" "-g                               "
    npm ERR! cwd /var/www/test/data/www/test.ru/wp-content/themes/unders                               trap/sass/theme
    npm ERR! node -v v0.10.4
    npm ERR! npm -v 1.2.18
    npm http 200 https://registry.npmjs.org/vinyl-fs
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /var/www/test/data/www/test.ru/wp-content/themes/unders                               trap/sass/theme/npm-debug.log
    
    На версии что ли ругается? Я не пойму как читать эти ошибки..
     
  2. aurora2000

    aurora2000 Постоялец

    Регистр.:
    24 авг 2014
    Сообщения:
    75
    Симпатии:
    22
    обновите npm
     
    Absolute и Menro нравится это.
  3. Menro

    Menro web, seo, email, hack

    Регистр.:
    27 янв 2008
    Сообщения:
    626
    Симпатии:
    125
    Спасибо, попробовал обновить - сломалось всё к чертям)
    Придётся дёргать своего сисадмина, что бы установил всё как надо.
     
  4. 01K

    01K

    Регистр.:
    27 июн 2013
    Сообщения:
    313
    Симпатии:
    44
    Возможно кроме NPM надо обновить все пакеты/зависимости. Что лучше попробовать сделать с резервной копией
     
  5. adsprosto

    adsprosto Писатель

    Регистр.:
    12 ноя 2013
    Сообщения:
    5
    Симпатии:
    0
    Как вариант, попробуйте переустановить node,npm пакеты
     
  6. dava1boy

    dava1boy Писатель

    Регистр.:
    13 июл 2017
    Сообщения:
    1
    Симпатии:
    0
    Здравствуйте, попробуйте переустановить node.js на более новую версию, обновите npm.
    Не забудьте проверить правильно ли обновилось:
    node -v
    npm -v
    Если все правильно вы увидите версию обновленных node и npm:)
     
  7. AuraBoga

    AuraBoga Писатель Нарушитель

    Регистр.:
    9 июн 2017
    Сообщения:
    3
    Симпатии:
    0
    Здесь 100% нужно обновлять npm и node
     
  8. saneklad

    saneklad Создатель

    Регистр.:
    29 фев 2016
    Сообщения:
    11
    Симпатии:
    0
    Версия 0.10 уже как год не поддерживается.
    Как выше сказали - обязательно обновление.
    Так же советую проверить не установлены ли несколько версий. Вообще лучше версионностью Node управлять через nvm