Модуль DLE Блок последний тем форума IPB

Тема в разделе "DLE", создана пользователем Non-Stop, 13 ноя 2015.

Информация :
Актуальная версия DataLife Engine 11.2
( Final Release v.11.2 | Скачать DataLife Engine | Скачать 11.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. Non-Stop

    Non-Stop

    Регистр.:
    9 июл 2007
    Сообщения:
    324
    Симпатии:
    25
    Пытаюсь поставить данный мод на dle 10.5 - блок не выводится.
    Хотя на 10,2 пробовал пару месяцев назад - он встал.

    Различия в установке:

    Код:
    1) Открыть файл index.php
    
    После строки:
    require_once ROOT_DIR.'/engine/init.php';
    
    Вставить
    require_once ENGINE_DIR.'/modules/block_forum.php';
    
    2) После
    $tpl->load_template('main.tpl');
    
    Вставить
    $tpl->set('{last_post_on_forum}', last_forum_posts());
    $tpl->set('{birthday_block}', birthday_user_forum());
    В 10,5 вывод темплейтов вынесено в файл /engine/modules/main.php
    Поэтому вторую часть вставил именно в /engine/modules/main.php адаптировав под тип вывода остальных
    Код:
    $tpl->set ( '{last_post_on_forum}', $tpl->result['last_forum_posts'] );
    $tpl->set ( '{birthday_block}', $tpl->result['birthday_user_forum'] );
    В админке мод включил - но блока на сайте нет.

    Подскажите где ещё ковырнуть?

    ps Для тех у кого UTF версия, пересохраните в utf8 языковый файл
     

    Вложения:

    Последнее редактирование: 13 ноя 2015
  2. Non-Stop

    Non-Stop

    Регистр.:
    9 июл 2007
    Сообщения:
    324
    Симпатии:
    25
    Неужели никто не ставил на новые версии ДЛЕ данный блок?
    Поделитесь пожалуйста рабочим вариантом или помогите решить вопрос вывод блока на сайт ..
     
  3. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.036
    Симпатии:
    2.039
    С ходу - а в шаблон ты всё вставил? Кэш почистил?
     
  4. Non-Stop

    Non-Stop

    Регистр.:
    9 июл 2007
    Сообщения:
    324
    Симпатии:
    25
    Всё сделал пошагово по инструкции. Кеш чистил. В админке блок тоже включил.
    Единственное различие с 10,2 описал..
    Там еще отличия в пунктуации есть.
    По инструкции в файл index.php
    Код:
    $tpl->set('{last_post_on_forum}', last_forum_posts());
    $tpl->set('{birthday_block}', birthday_user_forum());
    в main.php пунктуация немного другая,
    Код:
    $tpl->set ( '{last_post_on_forum}', $tpl->result['last_forum_posts'] );
    $tpl->set ( '{birthday_block}', $tpl->result['birthday_user_forum'] );
    если вставить код в main.php как в инструкции - ругаеся

    В итоге в исходном коде страницы нет ни тега {last_post_on_forum} ни кода блока

    может проблема в пунктуации?
     
    Последнее редактирование модератором: 23 ноя 2015
  5. inmy

    inmy

    Регистр.:
    13 апр 2012
    Сообщения:
    296
    Симпатии:
    200
    ошибки покаж что выдает,логи на сервере смотри,не все показывает что пишет в логи
     
  6. Non-Stop

    Non-Stop

    Регистр.:
    9 июл 2007
    Сообщения:
    324
    Симпатии:
    25
    Спасибо всем кто откликнулся. тк причину глюка так и не нашёл, проблему решил установкой другого мода.