Ошибка создания изображений prestashop / nginx + php-fpm

Тема в разделе "PrestaShop", создана пользователем alpi, 9 окт 2015.

Метки:
Информация :
Приветствую гость, обрати внимание! Темы которые закреплены в разделах, в скором времени будут откреплены. Правила раздела PrestaShop

(Не актуальные темы) Каталоги:Модули PrestaShop 1.7Модули PrestaShop 1.5 - 1.6Шаблоны PrestaShop 1.7Шаблоны PrestaShop 1.5 - 1.6
(Не актуальные темы) Поиск / Запросы:Модули PrestaShop 1.7Модули PrestaShop 1.5 - 1.6Шаблоны PrestaShop 1.7Шаблоны PrestaShop 1.5 - 1.6
Полезная информация:Поддержка и помощь c PrestaShopУбираем ПрестаТраст, стучалки и прочую рекламуСовместные покупки модулей и шаблоновПеревод Prestashop и модулей
Статус темы:
Закрыта.
Модераторы: trace
  1. alpi

    alpi human being

    Регистр.:
    29 июл 2014
    Сообщения:
    243
    Симпатии:
    232
    Есть: centos 7 / nginx / php-fpm и магазин на prestashop.

    Скрипт выгрузки из 1с копирует файлы в каталог site.com/upload/, и оттуда вызывает встроенные функции престы для обработки изображений. По какой-то причине файлы не копируются в нужные папки престы, так же не вызывается обработчик - генератор ЧПУ. но ссылки на изображения создаются, хотя самих изображений в папках нет : i.imgur.com/RTrSGC3.png ; i.imgur.com/6prBlY8.png

    Нигде в логах нет никаких ошибок при выгрузке товара. Вообще ноль. Как это можно отследить, и что это может быть? Грешил на права на файлы / пользователя - но пользователь вроде правильный, нужные права установлены. Причём на тот же сайт на другом сервере на апаче без проблем всё выгружается/создаётся (да и на nginx на другом сервере работало)

    Нужны идеи, предложения где посмотреть, на что обратить внимание. Если нужны конфиги - выложу.
     
  2. metsys

    metsys

    Регистр.:
    27 апр 2014
    Сообщения:
    540
    Симпатии:
    547
  3. alpi

    alpi human being

    Регистр.:
    29 июл 2014
    Сообщения:
    243
    Симпатии:
    232
    дело не в рерайтах, на этом конфиге nginxa у меня прописаны рерайты, и всё ещё недавно работало. другие скрипты работают, никаких проблем нет. только с этими изображениями и генерацией чпу.
     
Статус темы:
Закрыта.