[Помогите] Слетает сайт при добавлении ROBOTS.txt

Тема в разделе "Wordpress", создана пользователем VIP2013, 3 сен 2015.

Модераторы: DzSoft, Sorcus
  1. VIP2013

    VIP2013

    Регистр.:
    4 мар 2013
    Сообщения:
    203
    Симпатии:
    107
    В работе с WP я новичок, сделал хороший сайт, но вот проблема - при добавлении ROBOTS.txt сайт становиться кривой. Кто сталкивался с подобной проблемой? куда копать?
     
  2. ultra

    ultra

    Moderator
    Регистр.:
    15 ноя 2011
    Сообщения:
    215
    Симпатии:
    329
    сайт бы увидеть, до и после
    да и содержимое файла не помешало бы
     
  3. VIP2013

    VIP2013

    Регистр.:
    4 мар 2013
    Сообщения:
    203
    Симпатии:
    107
    Завтра скину в ЛС. Спасибо
     
  4. vita189

    vita189 Постоялец

    Регистр.:
    23 сен 2011
    Сообщения:
    82
    Симпатии:
    38
    Быть такого не может, это просто идентификатор для поисковых систем. Аналогично если я добавлю readme.txt - на сайт никакого влияния не оказывает. Другое дело, если сайт криво отображается для поисковой системы (блокирование css).
     
  5. VIP2013

    VIP2013

    Регистр.:
    4 мар 2013
    Сообщения:
    203
    Симпатии:
    107
    оказалось, что при добавлении файла на хостинг стирался файл шаблона. Даже не знаю почему. Хостер решил проблему
     
  6. vita189

    vita189 Постоялец

    Регистр.:
    23 сен 2011
    Сообщения:
    82
    Симпатии:
    38
    Всякое я повидал за время разработок сайтов, но я даже предположить не могу как такое возможно. :eek: ROBOTS.txt записывается в корень сайта, файлы шаблона лежат в другой структуре. Мистика.
     
  7. VIP2013

    VIP2013

    Регистр.:
    4 мар 2013
    Сообщения:
    203
    Симпатии:
    107
    Сейчас вот несколько раз эксперемент провел и выяснилось. В WP стоит галочка - не индексировать сайт, как только снимаешь галочку и даешь разрешение на индекс слетает шаблон. При этом в робот тхт прописываеться разрешение на индекс.