[IONCube] Странное поведение скрипта

Тема в разделе "Защита и взлом", создана пользователем droid, 5 авг 2015.

  1. droid

    droid Создатель

    Регистр.:
    2 авг 2011
    Сообщения:
    29
    Симпатии:
    4
    Добрый день коллеги.
    Имею интересное поведение скрипта накрытого кубиком. Установил на свой хост систему, она вся накрта кубиком. Стартует система, странички отображаются исполняются. При попытке создания нового объекта в системе получаю новое окно, но вместо формы сообщение о том что зенд не установлен.
    Имею рабочий хост с такой же системой, зенда там нет все работает корректно. Проверил md5 суммы файлов - совпадают.
    Возникает вопрос, это какая то блокировка от кубика? Можно ли это определить или это гдето некорректно настроенный софт у меня?
     
  2. TrueStory

    TrueStory

    Регистр.:
    30 апр 2015
    Сообщения:
    176
    Симпатии:
    52
    сравните параметры в php.ini
     
  3. droid

    droid Создатель

    Регистр.:
    2 авг 2011
    Сообщения:
    29
    Симпатии:
    4
    Сравинил, различия были не критические (отображение ошибок). Других отличий в ini файлах нет :(. Кто может подсобить?
    Есть момент, php -v говорит
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.0.14, Copyright (c) 2002-2015, by ionCube Ltd.
    а на второй машине IPS не говорит что он unconfigured.
     
  4. Meberas

    Meberas Создатель

    Регистр.:
    1 мар 2014
    Сообщения:
    10
    Симпатии:
    1
    попробуйте внутри файла посмотреть версию ioncube внутри файлов