Помощь Переезд на 2.х.х.

Тема в разделе "Opencart", создана пользователем NaviCross, 26 июл 2015.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
Модераторы: ZiX
  1. NaviCross

    NaviCross Создатель

    Регистр.:
    27 апр 2015
    Сообщения:
    42
    Симпатии:
    1
    Всем доброго времени суток!

    Не заметил как появилась возможность создавать темы.
    Дабы не плодить тучу вопросов в разных. задам тут.
    Решил переехать на вторую версию опенкарта.
    Сейчас пользуюсь сборкой OCshop 1.5.6.1. Все очень хорошо, но есть серьезные проблемы с совместимостью шаблонов и модулей(


    Итак.
    переезжаю на 2.0.3.1
    Шаблоном выбрал Coloring
    Корзина - Simple
    SEO менеджер - Paladin (таки заставил его работать)

    Ищу модуль новой почты с совместимостью к Симплу.
    Хотелось бы удобную работу с категориями и товарами(на дефолте я не могу даже товары по категориям отсеять)


    И вопрос, гугл бот должен видеть страницу как пользователь или как робот(без стилей)
    При проверке пишет что сайт не оптимизирован для мобильных устройств, хотя он оптимизирован.


    Ох, надеюсь я вас не утомил и спасибо за внимание.


    Да, я перенес все товары, категории, покупателей и историю заказов.
    Если что, могу помочь.
     
    Последнее редактирование: 26 июл 2015
  2. animal_x

    animal_x

    Регистр.:
    22 июн 2012
    Сообщения:
    400
    Симпатии:
    127
    Могу ответить только на эту часть: гугл сейчас должен видеть и умеет это делать как и пользователь, он умеет распознавать и стили и скрипты, поэтому для него открывайте скрипты и стили которые использует сайт.
    По всему этому поводу можешь почитать эту статью
     
  3. NaviCross

    NaviCross Создатель

    Регистр.:
    27 апр 2015
    Сообщения:
    42
    Симпатии:
    1
    Большое спасибо!
    Так и думал, только можно как для идиота, что удалить из стандартного файла Robots.txt?
     
  4. Vasyanya

    Vasyanya Постоялец

    Регистр.:
    11 май 2015
    Сообщения:
    53
    Симпатии:
    3
    2.0.х как по себе?норм?
    Стоит переезжать если и так все норм?
     
  5. vlad5050

    vlad5050 Создатель

    Регистр.:
    3 янв 2014
    Сообщения:
    32
    Симпатии:
    1
    Вообще-то от добра добра не ищут) Попробуйте паральлельно потестить, а там и определитесь
     
  6. NaviCross

    NaviCross Создатель

    Регистр.:
    27 апр 2015
    Сообщения:
    42
    Симпатии:
    1
    Если все работает и устраивает, зачем переезжать?

    В моем случае просто сборка слабосовместима с большинством шаблонов. поэтому и задумался о переезде.
     
  7. ninjaNeko

    ninjaNeko Постоялец

    Регистр.:
    4 окт 2008
    Сообщения:
    74
    Симпатии:
    8
    Мне вот тоже интерестно пощупать и возможно перейти, так как у 1.5.6, да и вообще у ветки 1.5 есть огромный минус это откатывать или очищать все если что-то пошло не так. К примеру поставил новый шаблон, а он со своими модулями и переписывает часть файлов в итоге после таго как шаблон удалил, все полетело. Есть конечно престашоп на котором вроде все есть и много чего уже из коробки плюс модули там отдельно прописываются, но вот экпорт импорт там кривой
     
  8. NaviCross

    NaviCross Создатель

    Регистр.:
    27 апр 2015
    Сообщения:
    42
    Симпатии:
    1
    У меня уже привычка, перед каждой установкой модуля или шаблона - бекап БД и архивация сайта)
     
  9. olegfusion

    olegfusion Постоялец

    Регистр.:
    19 мар 2012
    Сообщения:
    79
    Симпатии:
    8
    можно подумать у 2.0.x нет этого недостатка! те же проблемы
     
  10. Fansmorgan

    Fansmorgan

    Регистр.:
    30 авг 2007
    Сообщения:
    922
    Симпатии:
    161
    Не вижу смысла перевода ИМ на ветку 2.х ! разве что из-за обновлений ... будет ли ветка 1.5.х в дальнейшем обновляться - неизвестно !
    ТС, а вам совет - вот когда найдете все модули для 2.х, тогда и переводите ИМ на неё !
    Переводите на локальном сервере сначала, а потом уж и на реальный ...
     
    ninjaNeko нравится это.