Помощь DLE MAPS 0.2.2 под 10.4

Тема в разделе "DLE", создана пользователем gusewww, 18 май 2015.

Информация :
Актуальная версия DataLife Engine 11.3
( Final Release v.11.3 | Скачать DataLife Engine | Скачать 11.3 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.2 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. gusewww

    gusewww

    Регистр.:
    4 июл 2011
    Сообщения:
    670
    Симпатии:
    300
    Ребята, давайте подгоним сей мод под dle 10.4
    Первая проблема была с установкой(не устанавливался), решается так:
    Найти файл:
    engine/inc/maps.php
    Заменить
    ENGINE_DIR . '/modules/maps/install.php';
    на
    include_once ENGINE_DIR . '/modules/maps/install.php';

    Скачать мод можно тут: Перейти по ссылке

    Дальше проблема упирается в то что карта не выводится при попытке создать новость, ни в админке ни в фронтенде.
    Может кто уже разбирался?
     
  2. killoff

    killoff CD тихо, и не DVD меня ;)

    Moderator
    Регистр.:
    13 май 2008
    Сообщения:
    2.166
    Симпатии:
    795
    Судя по описанию сего модуля он вообще изначально разрабатывался под версию 8.3, спустя после которой было не мало изменений не только в шаблонах двига но и в самом коде, а также БД. Самое простое из того что приходит на ум - сравнить все запросы в БД в версии этого модуля и последней... /* со временем пока вообще рама, и локальный опенсервер отказывается работать нормально, но говоря уже о денвере... */
     
    gusewww нравится это.
  3. inmy

    inmy

    Регистр.:
    13 апр 2012
    Сообщения:
    308
    Симпатии:
    204
    там много устаревших констант,нужно режим глобальной отладки включать в модулей и смотреть что и где косячит.как правило много устаревших функций
     
  4. inmy

    inmy

    Регистр.:
    13 апр 2012
    Сообщения:
    308
    Симпатии:
    204
    попробуй запустить этот,случайно нарыл адаптированный под 8.0 - 10.2 кнутом,но по факту даже не ставил,некуда применить его даже
     

    Вложения:

    gusewww нравится это.