Помощь Проблемка с кодировкой только в шапке

Тема в разделе "Opencart", создана пользователем spamhost, 22 апр 2015.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
Модераторы: ZiX
  1. spamhost

    spamhost

    Регистр.:
    29 апр 2009
    Сообщения:
    259
    Симпатии:
    143
    Оригинальная OC 2.0.1.1 c установленным с сайта opencart русским языком. Шапка выводится с неверным отображением спецсимволов. Перевод header.tpl в UTF-8, файлы языка тоже в UTF-8 проблемы не решили. Куда копать?
     

    Вложения:

  2. kir9-molodoi

    kir9-molodoi

    Регистр.:
    31 май 2014
    Сообщения:
    251
    Симпатии:
    79
    похоже что не подключены шрифты, попробуйте подключить font awesome
     
    spamhost нравится это.
  3. spamhost

    spamhost

    Регистр.:
    29 апр 2009
    Сообщения:
    259
    Симпатии:
    143
    Да, к Вашему ответу уже подошел сам в ковырянии и даже скачал обновленную версию font-awesome-4.3.0, но не помогло.
    Дело в том, что два домена, где один просто паркован к другому и на одном корректно показывает, а на другом (паркованном) - нет. Также некорректно эти символы отображаются на обоих сайтах - в виде квадратиков в Google Chrome, в остальных браузерах отлично (на основном сайте). Как проверить подключение этих шрифтов?
     
  4. gusewww

    gusewww

    Регистр.:
    4 июл 2011
    Сообщения:
    670
    Симпатии:
    300
    вместо http вставить // или s, ох уж эти шрифты. Гуглите в ангоязычном секторе, все это есть.
    смотрим пример Перейти по ссылке, если все работает в разных браузерах то код подсмотреть, надеюсь, не проблема.
     
  5. spamhost

    spamhost

    Регистр.:
    29 апр 2009
    Сообщения:
    259
    Симпатии:
    143
    В исходнике OC 2.0.1.1 header.tpl такое
    <link href="catalog/view/javascript/font-awesome/css/font-awesome.min.css" rel="stylesheet" type="text/css" />

    нет там http

    Никакие эксперименты с // ничего не дали. Проблема пока не решена.
     
  6. gusewww

    gusewww

    Регистр.:
    4 июл 2011
    Сообщения:
    670
    Симпатии:
    300
    Попробуй так:
    <link href="Перейти по ссылке" media="all" rel="stylesheet" type="text/css">
    Или так
    <link href="/catalog/view/javascript/font-awesome/css/font-awesome.min.css" media="all" rel="stylesheet" type="text/css">
     
    spamhost нравится это.
  7. spamhost

    spamhost

    Регистр.:
    29 апр 2009
    Сообщения:
    259
    Симпатии:
    143
    Вариант с <link href="Перейти по ссылке" media="all" rel="stylesheet" type="text/css">
    рабочий. Пока остановлюсь на нем, хотя непонятно, почему такие недоработки в OpenCart.
     
  8. kir9-molodoi

    kir9-molodoi

    Регистр.:
    31 май 2014
    Сообщения:
    251
    Симпатии:
    79
    это не недоработки опенкарт, это недоработки темы которую используете ))
     
    gusewww нравится это.
  9. spamhost

    spamhost

    Регистр.:
    29 апр 2009
    Сообщения:
    259
    Симпатии:
    143
    Вообще-то тема что ни на есть оригинальная, идущая с Opencart 2.0.1.1, поэтому недоработка именно в Opencart.
     
  10. VaLeXaR

    VaLeXaR Создатель

    Регистр.:
    5 апр 2013
    Сообщения:
    45
    Симпатии:
    16
    Создавал не одну тему основанную на базовой теме Opencart. Такой проблемы не встречал. Проверьте правильность подключения шрифта. Тот, который идет с оригинальной темой нормально функционирует.