[Помогите] Сайт содержит слишком много перенаправлений

Тема в разделе "Wordpress", создана пользователем ezanich, 21 янв 2015.

Модераторы: Sorcus
  1. ezanich

    ezanich Создатель

    Регистр.:
    22 мар 2013
    Сообщения:
    48
    Симпатии:
    1
    Код .htaccess соответственно:

    появляется ошибка при попытке замутить 301 редирект без www.
    Пытался осуществить это последними 3-я строками кода, поочерёдно уже подтыкивал в каждую строку - результат один, как только вбиваю в коде корректное имя сайта вместо site.ru, ресурс выпадает в осадок и выдаёт что стоит бесконечная переадресация...
    Как быть, куда деваться, может кто сталкивался?
    Как ни странно заработал вот такой вариант:

    но мне то нужно не с www, а наоборот без него, поэтому поменяв немного код:

    я хотел было думать что наконец-то всё заработало, но нет, опять вечный редирект...
     
    Последнее редактирование: 21 янв 2015
  2. Solus_Rex

    Solus_Rex

    Регистр.:
    15 янв 2012
    Сообщения:
    425
    Симпатии:
    179
    Вот это в коде есть:
    Options +FollowSymLinks
    ?

    Попробуйте вот это вставить в начало файла:
    Код:
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    </IfModule> 
     
    Последнее редактирование: 21 янв 2015
  3. ezanich

    ezanich Создатель

    Регистр.:
    22 мар 2013
    Сообщения:
    48
    Симпатии:
    1
    не помогло, к сожалению.
     
  4. Solus_Rex

    Solus_Rex

    Регистр.:
    15 янв 2012
    Сообщения:
    425
    Симпатии:
    179
    А вот так?
    Код:
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^www\.(.*) [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
    </IfModule> 
     
    ezanich нравится это.
  5. ezanich

    ezanich Создатель

    Регистр.:
    22 мар 2013
    Сообщения:
    48
    Симпатии:
    1
    Та же хренотень...
     
  6. xoxmo

    xoxmo Постоялец

    Регистр.:
    24 мар 2008
    Сообщения:
    142
    Симпатии:
    86
    если у вас в настройках сайта адрес указан с www, то при заходе на сайт без www он будет перекидывать на адрес с www.
    так и получается вечная петля и множество перенаправлений.
    смените урл сайта на адрес без www ( /wp-admin/options-general.php ).
    тут написано, как правильно менять адрес сайта.
     
    Solus_Rex и ezanich нравится это.
  7. ezanich

    ezanich Создатель

    Регистр.:
    22 мар 2013
    Сообщения:
    48
    Симпатии:
    1
    Спасибо за участие.
    Спасибо, всё проще простого оказалось. Я просто привык в коде ковыряться, а тут такие мелочи уже предусмотрены.
     
  8. Solus_Rex

    Solus_Rex

    Регистр.:
    15 янв 2012
    Сообщения:
    425
    Симпатии:
    179
    Точно, это ж WP... Не посмотрел на рубрику... :D
    **я, во я лох... :)