Проблемы с блоком многоуровневой навигации

Тема в разделе "PrestaShop", создана пользователем alekse, 9 янв 2015.

Информация :
Хочешь в разделе без проблем общаться - прочти правила, чтобы потом с форумом на время не прощаться. Читать обязательно!
Внимание! Читайте внимательно правила!Предупреждения выдаются без всяких вопросов. Нарушил - получил. Будьте Внимательнее! Постинг нескольких постов подряд приравнивается к НАРУШЕНИЮ! Будьте вежливы и соблюдайте правила ;-)
Модераторы: NightHunter, ZiX
  1. alekse

    alekse

    Регистр.:
    19 июн 2007
    Сообщения:
    694
    Симпатии:
    120
    Текущая версия блока многоуровневой навигации 2.0.6
    Проблема в следующем (по шагам)
    1. заходим на страницу категории по ссылке test.com/ru/5-cat
    2. выбираем производителя Addidas нажав на его название в фильтре, но не на чек-бокс (это важно) - PS нам выдал правильный результат, УРЛ имеет следующий формат test.com/ru/5-cat#/manufacturer-addidas
    3. сбрасываем фильтр производителя, УРЛ получится вида test.com/ru/5-cat# (по сравнению с изначальным вариантом 1 добавился #)
    4. снова нажимаем на значение фильтра производителя, но не на чек-бокс (это важно) - и теперь фильтр не устанавливается! Если значение фильтра выбирать не по нажатию на это значение, а нажатием на сам чек-бокс этого значения то фильтр устанавливается правильно. Сама ссылка значения фильтра (отображается при наведении курсора на нее) следующая test.com/ru/5-cat#manufacturer-addidas
    Помогите с решением проблемы... Почему так получается что по нажатию на чек-бокс фильтр работает всегда, а по нажатию на само значение фильтр срабатывает только если изначальный УРЛ был без # в конце, который остается после сброса фильтра?