Помощь Обновление с 1.5х до 2.0.х

Тема в разделе "Opencart", создана пользователем Otto, 30 дек 2014.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
Модераторы: ZiX
  1. Otto

    Otto

    Регистр.:
    12 май 2008
    Сообщения:
    481
    Симпатии:
    158
  2. unfume

    unfume Редиска

    Регистр.:
    20 янв 2014
    Сообщения:
    519
    Симпатии:
    206
    Не реально, даже не думай
     
  3. NinoZombie

    NinoZombie Постоялец

    Регистр.:
    27 окт 2013
    Сообщения:
    117
    Симпатии:
    28
    Конечно реально, но нелегко, так как во 2-м опенкарте сильно поменялась структура БД и логика. Советую ознакомиться со статьей http://sv2109.com/ru/article/перенос-модулей-с-opencart-15x-на-opencart-20x-mini-howto-или-изменения-в-opencart-20
    Упомянутый Вами модуль приводит структуру базы данных опенкарта версии 1.5 к виду 2.0. Как по мне, так это лишние грабли, брошенные на пути к нормальному сайту
     
  4. Otto

    Otto

    Регистр.:
    12 май 2008
    Сообщения:
    481
    Симпатии:
    158
    Да если никаких модулей не устанавливать, а чисто 1.5 обновить до 2.0. т.е. с базовым функционалом
     
  5. NinoZombie

    NinoZombie Постоялец

    Регистр.:
    27 окт 2013
    Сообщения:
    117
    Симпатии:
    28
    Тогда резонно встает вопрос "Зачем?" :)
    Чтобы шаблон перенести под 2.0 ? Ну так ничего и не изменится тогда, с большой вероятностью. Только вот вызовы контроллеров для шаблона, назначение переменных и прочее переделывать руками придется, как в статье описано.
     
  6. Otto

    Otto

    Регистр.:
    12 май 2008
    Сообщения:
    481
    Симпатии:
    158
    Ну согласитесь что у OC 1.5.х тупая админка по сравнению с 2.0, вот эту версию и хочу, а шаблон нравится от 1.5.х ((
     
  7. Dizees

    Dizees Постоялец

    Регистр.:
    22 июл 2012
    Сообщения:
    59
    Симпатии:
    17
    Не рекомендую т.к. модули и шаблон необходимо также обновлять до необходимой версии, а с этим могут возникнуть проблемы совместимости.
    При переходе может возникнуть больше проблем чем пользы
     
  8. madmaximus85

    madmaximus85 Постоялец

    Регистр.:
    30 июл 2012
    Сообщения:
    98
    Симпатии:
    51
    Тему админки можно обновить Circloid вполне себе удобная тема и была в разделе форума платные модули
     
  9. NinoZombie

    NinoZombie Постоялец

    Регистр.:
    27 окт 2013
    Сообщения:
    117
    Симпатии:
    28
    Admin Quick Edit с ней работает?
     
  10. madmaximus85

    madmaximus85 Постоялец

    Регистр.:
    30 июл 2012
    Сообщения:
    98
    Симпатии:
    51
    в моем случае все в связке работало 2.1.4 AQE + 1.5.6.1 OC + Circloid

    не работал он только когда подключал модуль сортировки перетягиванием drag&drop sort.
     
    Последнее редактирование: 8 янв 2015
    NinoZombie нравится это.