Запустить файл под зенд на php 5.4

Тема в разделе "Защита и взлом", создана пользователем verfaa, 6 дек 2014.

Статус темы:
Закрыта.
  1. verfaa

    verfaa

    Регистр.:
    29 янв 2007
    Сообщения:
    371
    Симпатии:
    41
    Работал у меня раньше дорген архангела на впс с php 5.2
    Недавно переехал на другой впс с php 5.4 и зазенденные файлы отказались работать, выдают ошибку
    Код:
    Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects 5 in /home/archangel-dorgen/admin.php on line 0
    Модуль для запуска зазенденных файлов подключен:
    Код:
    # php -v
    PHP 5.4.35 (cli) (built: Nov 19 2014 08:57:02)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
        with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
        with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies
    
    Как можно запустить зазенденные файлы на php 5.4?
     
  2. qpPeW

    qpPeW Постоялец

    Регистр.:
    5 окт 2009
    Сообщения:
    80
    Симпатии:
    31
    Версия PHP не совпадает с версией Encoder(a), маловероятно что Вы даже запустить на 5.3, скорее всего Ваш скрипт закодирован под 5.2
     
  3. stealthdebuger

    stealthdebuger Механик

    Administrator
    Регистр.:
    25 авг 2008
    Сообщения:
    624
    Симпатии:
    1.379
    У вас только один выход - снимать зенд.
     
  4. xtmp

    xtmp Постоялец

    Регистр.:
    18 янв 2014
    Сообщения:
    60
    Симпатии:
    24
    Анекдот на тему:
    - Вам удалось запустить зенд на php 5.4 ?
    - Да, я установил IonCube.

    Пробуйте IonCube, мне помог.
     
Статус темы:
Закрыта.