XAMMP v.3.2.1 на Win - error 403, Access forbidden!

Тема в разделе "Мегафлуд", создана пользователем soot, 6 дек 2014.

  1. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    Установил XAMMP из коробки не чего не менял, кроме конфигов по этой инструкции http://makegood.ru/tools/xampp/.

    Выдает ошибку:
    [​IMG]


    Файлы index.html и index.php есть по адресу: local/www/ - т.е. в той которая прописана в конфигах.


    httpd-vhosts.conf:
    Код:
    # Virtual Hosts
    #
    # Required modules: mod_log_config
    
    # If you want to maintain multiple domains/hostnames on your
    # machine you can setup VirtualHost containers for them. Most configurations
    # use only name-based virtual hosts so the server doesn't need to worry about
    # IP addresses. This is indicated by the asterisks in the directives below.
    #
    # Please see the documentation at
    # <URL:http://httpd.apache.org/docs/2.4/vhosts/>
    # for further details before you try to setup virtual hosts.
    #
    # You may use the command line option '-S' to verify your virtual host
    # configuration.
    
    #
    # Use name-based virtual hosting.
    #
    ##NameVirtualHost *:80
    #
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for all requests that do not
    # match a ##ServerName or ##ServerAlias in any <VirtualHost> block.
    #
    ##<VirtualHost *:80>
        ##ServerAdmin webmaster@dummy-host.example.com
        ##DocumentRoot "C:/xampp/htdocs/dummy-host.example.com"
        ##ServerName dummy-host.example.com
        ##ServerAlias www.dummy-host.example.com
        ##ErrorLog "logs/dummy-host.example.com-error.log"
        ##CustomLog "logs/dummy-host.example.com-access.log" common
    ##</VirtualHost>
    
    ##<VirtualHost *:80>
        ##ServerAdmin webmaster@dummy-host2.example.com
        ##DocumentRoot "C:/xampp/htdocs/dummy-host2.example.com"
        ##ServerName dummy-host2.example.com
        ##ErrorLog "logs/dummy-host2.example.com-error.log"
        ##CustomLog "logs/dummy-host2.example.com-access.log" common
    ##</VirtualHost>
    
    NameVirtualHost *:80
    
    <VirtualHost *:80>
        DocumentRoot "C:\xampp\htdocs"
        ServerName localhost
    </VirtualHost>
    
    <VirtualHost *:80>
        ServerAdmin webmaster@local
        DocumentRoot "C:\my_projects\local\www"
        ServerName lserver.ru
        ServerAlias www.lserver.ru
        ErrorLog "C:\my_projects\local\logs\error.log"
        CustomLog "C:\my_projects\local\logs\access.log" combined
      <Directory "C:\my_projects\local\www">
        Options Indexes FollowSymLinks Includes execCGI
        AllowOverride All
        Order allow,deny
        Allow from all
      </Directory>
    </VirtualHost>
    
    host:
    Код:
    127.0.0.1 lserver.ru
    127.0.0.1 www.lserver.ru
    httpd-xampp.conf:
    Код:
    #
    # XAMPP settings
    #
    
    <IfModule env_module>
        SetEnv MIBDIRS "C:/xampp/php/extras/mibs"
        SetEnv MYSQL_HOME "\\xampp\\mysql\\bin"
        SetEnv OPENSSL_CONF "C:/xampp/apache/bin/openssl.cnf"
        SetEnv PHP_PEAR_SYSCONF_DIR "\\xampp\\php"
        SetEnv PHPRC "\\xampp\\php"
        SetEnv TMP "\\xampp\\tmp"
    </IfModule>
    
    #
    # PHP-Module setup
    #
    LoadFile "C:/xampp/php/php5ts.dll"
    LoadFile "C:/xampp/php/libpq.dll"
    LoadModule php5_module "C:/xampp/php/php5apache2_4.dll"
    
    <FilesMatch "\.php$">
        SetHandler application/x-httpd-php
    </FilesMatch>
    <FilesMatch "\.phps$">
        SetHandler application/x-httpd-php-source
    </FilesMatch>
    
    #
    # PHP-CGI setup
    #
    #<FilesMatch "\.php$">
    #    SetHandler application/x-httpd-php-cgi
    #</FilesMatch>
    #<IfModule actions_module>
    #    Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
    #</IfModule>
    
    
    <IfModule php5_module>
        PHPINIDir "C:/xampp/php"
    </IfModule>
    
    <IfModule mime_module>
        AddType text/html .php .phps
    </IfModule>
    
    ScriptAlias /php-cgi/ "C:/xampp/php/"
    <Directory "C:/xampp/php">
        AllowOverride None
        Options None
        Require all denied
        <Files "php-cgi.exe">
              Require all granted
        </Files>
    </Directory>
    
    <Directory "C:/xampp/cgi-bin">
        <FilesMatch "\.php$">
            SetHandler cgi-script
        </FilesMatch>
        <FilesMatch "\.phps$">
            SetHandler None
        </FilesMatch>
    </Directory>
    
    <Directory "C:/xampp/htdocs/xampp">
        <IfModule php5_module>
            <Files "status.php">
                php_admin_flag safe_mode off
            </Files>
        </IfModule>
        AllowOverride AuthConfig
    </Directory>
    
    <IfModule alias_module>
        Alias /security "C:/xampp/security/htdocs/"
        <Directory "C:/xampp/security/htdocs">
            <IfModule php5_module>
                <Files "xamppsecurity.php">
                    php_admin_flag safe_mode off
                </Files>
            </IfModule>
            AllowOverride AuthConfig
            Require all granted
       </Directory>
    
        Alias /licenses "C:/xampp/licenses/"
        <Directory "C:/xampp/licenses">
            Options +Indexes
            <IfModule autoindex_color_module>
                DirectoryIndexTextColor  "#000000"
                DirectoryIndexBGColor "#f8e8a0"
                DirectoryIndexLinkColor "#bb3902"
                DirectoryIndexVLinkColor "#bb3902"
                DirectoryIndexALinkColor "#bb3902"
            </IfModule>
            Require all granted
       </Directory>
    
        Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
        <Directory "C:/xampp/phpMyAdmin">
            AllowOverride AuthConfig
            Require all granted
        </Directory>
    
        Alias /webalizer "C:/xampp/webalizer/"
        <Directory "C:/xampp/webalizer">
            <IfModule php5_module>
                <Files "webalizer.php">
                    php_admin_flag safe_mode off
                </Files>
            </IfModule>
            AllowOverride AuthConfig
            Require all granted
        </Directory>
    </IfModule>
    
    #
    # New XAMPP security concept
    #
    <LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
        Require local
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </LocationMatch>
    
     
  2. t0wer

    t0wer BlackHerald

    Регистр.:
    24 июн 2008
    Сообщения:
    731
    Симпатии:
    421
    Откатывайтесь к дефолтным конфигам от ксампа. Потом начинайте изменять конфиг поэлементно. Какой элемент выскочит, значит там косяк и ищите. А так лопатить целый файл конфига и тем более не видя, что там делали... Тут не "Битва экстрасенсов".
     
  3. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    Я установил только вот этот код в httpd-vhosts.conf:

    Код:
    NameVirtualHost *:80
    
    <VirtualHost *:80>
        DocumentRoot "C:\xampp\htdocs"
        ServerName localhost
    </VirtualHost>
    
    <VirtualHost *:80>
        ServerAdmin webmaster@local
        DocumentRoot "C:\my_projects\local\www"
        ServerName lserver.ru
        ServerAlias www.lserver.ru
        ErrorLog "C:\my_projects\local\logs\error.log"
        CustomLog "C:\my_projects\local\logs\access.log" combined
      <Directory "C:\my_projects\local\www">
        Options Indexes FollowSymLinks Includes execCGI
        AllowOverride All
        Order allow,deny
        Allow from all
      </Directory>
    </VirtualHost>
    Больше ни чего не делал.
     
  4. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    DocumentRoot "C:\my_projects\local\www" - это моя папка где лежит файл index.php и файл index.html

    Вот error.log
    [Sat Dec 06 11:21:29.694830 2014] [authz_core:error] [pid 15072:tid 1672] [client 127.0.0.1:61925] AH01630: client denied by server configuration: C:/my_projects/local/www/
    [Sat Dec 06 11:21:29.795836 2014] [authz_core:error] [pid 15072:tid 1672] [client 127.0.0.1:61925] AH01630: client denied by server configuration: C:/my_projects/local/www/favicon.ico
     
  5. qpPeW

    qpPeW Постоялец

    Регистр.:
    5 окт 2009
    Сообщения:
    80
    Симпатии:
    31
    Попробуйте удалить вот этот код
     
    soot нравится это.
  6. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    Удалил, апач остановил и снова запустил. Ошибка таже.
     
  7. qpPeW

    qpPeW Постоялец

    Регистр.:
    5 окт 2009
    Сообщения:
    80
    Симпатии:
    31
    .htaccess имееться в папке C:/my_projects/local/www/ ?
     
  8. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    нет

    От куда можно дернуть стандартный ?
     
  9. qpPeW

    qpPeW Постоялец

    Регистр.:
    5 окт 2009
    Сообщения:
    80
    Симпатии:
    31
    Я бы Вам советовал перейти на "Open Server", толковая вещь с приятным интерфейсом и без лишнего геморроя.
     
    zaxap83 и soot нравится это.
  10. soot

    soot

    Регистр.:
    22 дек 2008
    Сообщения:
    164
    Симпатии:
    28
    У меня есть еще макбук - дак XAMMP есть на макбук.
    Я хотел разобраться хотя бы в одной программе (сервере) - чтобы потом самостоятельно ...

    Раньше был денвер - он хорошо работал.