Помощь open cart + mySQL = error

Тема в разделе "Opencart", создана пользователем vava1, 11 сен 2014.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
Статус темы:
Закрыта.
Модераторы: ZiX
  1. vava1

    vava1 Постоялец

    Регистр.:
    21 апр 2013
    Сообщения:
    50
    Симпатии:
    3
    Решил попробовать поработать с данным движком.
    Подскажите пожалуйста, как исправить эту ужасную ошибку:
    Код:
    Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\OpenServer\domains\open\system\database\mysql.php on line 6
    Вся соль в том, что ставлю на локалке, используя Open Server у него нету ни Mysqli / PDO как быть?
    в php.ini писал
    Код:
    error_reporting = E_ALL & ~E_DEPRECATED;
    результата - ноль.
    использую последнею версию: 1.5.6
    В админке вообще жестит, ругается на сессии и что то еще.
     
  2. ricky jabrik

    ricky jabrik

    Регистр.:
    15 мар 2014
    Сообщения:
    170
    Симпатии:
    172
    может быть и можно попробовать это
     
  3. dandandan

    dandandan

    Регистр.:
    7 авг 2008
    Сообщения:
    975
    Симпатии:
    255
    Залазиешь в файлик
    C:\OpenServer\domains\open\system\database\mysql.php on line 6
    ищешь строку 6.
    В ней меняешь mysql_connect() на mysqli_connect() . Наслаждаешься.

    Это не проблема движка, а проблема вашей версии php. Видимо в следующей новой версии php перестане существовать функция mysql_connect() . Вот система и выводит Notice.
     
  4. unfume

    unfume Редиска

    Регистр.:
    20 янв 2014
    Сообщения:
    519
    Симпатии:
    206
Статус темы:
Закрыта.