Поставить ionCube для opencart

Тема в разделе "Администрирование серверов", создана пользователем wwizard, 4 июл 2014.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. wwizard

    wwizard

    Регистр.:
    20 июл 2009
    Сообщения:
    399
    Симпатии:
    12
    Сайт создан на opencart 1.5.5.1.2 - сайт Перейти по ссылке
    Для работы модулей нужно установить ionCube PHP Loader
    Смог поставить только версию 4.5. , но все модули OpenCart ругаются, так: Site error: the file /var/www/users/unit/domains/unit.od.ua/admin/suppler_license/suppler_ins.php requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

    Модули: автоматическое добавление товаров, Simple, чтото по шаблоную

    Не за бесплатно, готов оплатить труд. Очень надо. пожалуйста.
     
  2. LyToR

    LyToR Постоялец

    Регистр.:
    11 сен 2012
    Сообщения:
    145
    Симпатии:
    144
    Поставьте сайт у нормального хостера, и не будет никаких проблем с кубом.
     
  3. wwizard

    wwizard

    Регистр.:
    20 июл 2009
    Сообщения:
    399
    Симпатии:
    12
    Сервер свой. забыл написать
    Стоит: centos 6
    Сервер - supermicro на Intel(R) Xeon(R) CPU X3470 @ 2.93GHz
    HDD 2x1Tb Raid
    RAM 16Gb
     
  4. LyToR

    LyToR Постоялец

    Регистр.:
    11 сен 2012
    Сообщения:
    145
    Симпатии:
    144
    В таком случае вопрос не в эту тему, а в линукс раздел.
     
  5. wwizard

    wwizard

    Регистр.:
    20 июл 2009
    Сообщения:
    399
    Симпатии:
    12
    вот так стоит
    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
    with the ionCube PHP Loader v4.6.1, Copyright (c) 2002-2014, by ionCube Ltd., and
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans

    а всеравно модули не работают.
     
  6. metsys

    metsys

    Регистр.:
    27 апр 2014
    Сообщения:
    450
    Симпатии:
    434
    Поскольку в Вашем случае использовался кастом php.ini который лежал в корне сайта, также, необходимо было править кастом php.ini в папке admin, т.е. прописать
    zend_extension = /usr/lib/php/modules/ioncube_loader_lin_5.3.so
     
    wwizard нравится это.
Статус темы:
Закрыта.