Помощь ошибка в дополнительном поле

Тема в разделе "DLE", создана пользователем sotex2, 1 июл 2014.

Информация :
Актуальная версия DataLife Engine 11.3
( Final Release v.11.3 | Скачать DataLife Engine | Скачать 11.3 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.2 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. sotex2

    sotex2 Создатель

    Регистр.:
    9 июн 2014
    Сообщения:
    42
    Симпатии:
    1
    на движке dle 10.2 при добавлении новостей, я картинку вставляю в дополнительное поле. картинка выводиться как надо, но стоит мне в настройках движка включить автоматическую конвертацию ссылок, то вместо картинки выводится это
    [xfgiven_image]<img src="[xfvalue_image]" alt="{title}" width="200" height="150" border="0">[/xfgiven_image]. как исправить, чтоб выводилась картинка с включенной конвертацией ссылок.
     
  2. bork75

    bork75 The Team

    Регистр.:
    21 июн 2008
    Сообщения:
    1.450
    Симпатии:
    717
    Если в доп. поле используешь абсолютный путь до картинки, то попробуй относительный, а в коде, если надо, пропиши весь путь или только путь до папки
    Код:
    <img src="/folder/[xfvalue_image]" 
    
     
  3. sotex2

    sotex2 Создатель

    Регистр.:
    9 июн 2014
    Сообщения:
    42
    Симпатии:
    1
    и абсолютный путь и относительный прописывал, без результата. что характерно когда отключить конвертацию все выводится, как надо. почему?

    я сам сделал, загвозка была в том, что при добавлении дополнительного поля в настройках ниже нужно включить Безопасный режим поля (отключить поддержку BB тегов и HTML) и все будет ровно
     
    Последнее редактирование модератором: 2 июл 2014
    bork75 нравится это.