Обновление пыхи с 5.3 до 5.4 centos

Тема в разделе "Администрирование серверов", создана пользователем fairbug, 15 июн 2014.

Модераторы: mefish, stooper
  1. fairbug

    fairbug

    Регистр.:
    1 май 2013
    Сообщения:
    185
    Симпатии:
    64
    Господа админы, подскажите на собственном опыте, если таковой имеется, все подводные камни обновление пыхи на работающем сервере, на что надо обратить внимание, что отключить что подключить, как правильно и т.д. в общем интересует всё, понятно что геша всё знает, но времени собирать инфу по Псам нет, работы много...
     
  2. Rimon

    Rimon Постоялец

    Регистр.:
    14 апр 2013
    Сообщения:
    126
    Симпатии:
    88
    fairbug нравится это.
  3. metsys

    metsys

    Регистр.:
    27 апр 2014
    Сообщения:
    380
    Симпатии:
    384
    1) Не каждый сайт хорошо переживает обновление версии пыхи (например депрекейтед фунцкции, сессии) - поэтому подстрахуйтесь поставить какую то заглушку про проведение регламента.
    2) Забекапить конфиги, сайты.
    3) Проверьте из каких репов поставлена текущая версия, и что бы не было пересечений с другими репами.
    Лично я после нескольких наступаний на эти грабли, вывожу список установленных модулей пыхи, потом всё это сношу и накатываю то, что нужно.
    В некоторых случаях приходилось также поступить и с мускулом (из за зависимостей некоторых модулей).
     
    fairbug и Rimon нравится это.
  4. fairbug

    fairbug

    Регистр.:
    1 май 2013
    Сообщения:
    185
    Симпатии:
    64
    во, вот это уже интересно, просто на серваке стоит разнобой в смысле движек, начиная от ксенфоро,окси,опенкартов и заканчивая самописами, не охото как то это всё восстанавливать...
     
  5. metsys

    metsys

    Регистр.:
    27 апр 2014
    Сообщения:
    380
    Симпатии:
    384
    В этом случае крайне рекомендую создать локально (можно в виртуалке) аналогичную среду (ось+нужная версия пыхи) и протестировать каждый сайт, особенно самопис.
    Плюс контролируй еррор логи + логи движков, потому что внешне может не выявится проблема.
     
  6. aniucum

    aniucum Постоялец

    Регистр.:
    1 янв 2014
    Сообщения:
    120
    Симпатии:
    103
    Если стоит mariabd, то для неё обновление php может оказаться трагичным
     
    fairbug нравится это.
  7. fairbug

    fairbug

    Регистр.:
    1 май 2013
    Сообщения:
    185
    Симпатии:
    64
    к счастью не стоИт таковая