Балансировка mikrotik

Тема в разделе "Администрирование серверов", создана пользователем Roddy, 11 июн 2014.

Модераторы: mefish, stooper
  1. Roddy

    Roddy Создатель

    Регистр.:
    10 июн 2010
    Сообщения:
    36
    Симпатии:
    1
    Добрый день,
    не нашел раздела посвященного именно маршрутизаторам, поэтому задам вопрос в этой теме.
    настроил балансировку каналов от двух провайдеров (каждый 20mb\s) через nth
    все работает.
    /ip firewall mangle
    add action=add-src-to-address-list address-list=first chain="mark new unseen" nth=2,1
    add action=add-src-to-address-list address-list=second chain="mark new unseen" nth=2,2
    add action=add-src-to-address-list address-list=seen chain="mark new unseen"
    add action=jump chain="mark new unseen" jump-target="mark connection"
    add action=mark-connection chain="mark connection" new-connection-mark=first_conn src-address-list=first
    add action=mark-connection chain="mark connection" new-connection-mark=second_conn src-address-list=second
    add action=mark-routing chain="mark connection" connection-mark=first_conn new-routing-mark=first passthrough=no
    add action=mark-routing chain="mark connection" connection-mark=second_conn new-routing-mark=second passthrough=no
    add action=mark-routing chain=prerouting connection-mark=first_conn new-routing-mark=first passthrough=no \
    src-address-list=first
    add action=mark-routing chain=prerouting connection-mark=second_conn new-routing-mark=second passthrough=no \
    src-address-list=second
    add action=jump chain=prerouting connection-state=new jump-target="mark connection" src-address-list=local
    add action=jump chain=prerouting connection-state=new jump-target="mark new unseen" src-address-list=local
    /ip route
    add distance=1 gateway=ip_шлюз_пров1 routing-mark=first
    add distance=1 gateway=ip_шлюз_пров2 routing-mark=second
    add distance=1 gateway=ip_шлюз_пров1
    add distance=1 gateway=ip_шлюз_пров2
    + статичные маршруты с интерфейсов
    но при работающих правилах:
    Код:
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=first_conn disabled=no new-routing-mark=first passthrough=no src-address-list=first
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=second_conn disabled=no new-routing-mark=second passthrough=no src-address-list=second
    Напрочь отваливается пинг из локалки до самого маршрутизатора. При этом есть доступ до сервисов, через winbox, идет ping во внешку, одним словом все доступно. Если отключить правила то пинг работает.
    Может кто помочь разобраться почему это происходит? информацию не могу найти
     
  2. viczelen

    viczelen Постоялец

    Регистр.:
    2 июл 2012
    Сообщения:
    67
    Симпатии:
    11
    winbox он и так будет работать... даже без IP.
    пинг с роутера во внутренюю сеть идет?
     
  3. Roddy

    Roddy Создатель

    Регистр.:
    10 июн 2010
    Сообщения:
    36
    Симпатии:
    1
    да идет. до любого хоста.

    с проблемой разобрался,
    в адрес листе была указана лишняя запись с адресом 192.168.номер_подсети.0/24