1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Обсуждение Простое решение конфликта jquery

Тема в разделе "Joomla", создана пользователем spro1, 16 май 2014.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Модераторы: arman29, DMS, Genk0, NightHunter
  1. spro1

    spro1

    Регистр.:
    26 май 2013
    Сообщения:
    170
    Симпатии:
    70
    Всем привет!

    На днях столкнулся с довольно распространенной проблеммой, когда из-за конфликта jquery модуль слайдера unit revolution slider 2 не работал вместе с модулем корзины Sj Minicart Pro. Времени у меня было совсем мало, поэтому я даже не думал ковыряться и решать проблему, и уже было думал поставить другой слайдер, но тут вспомнил про интересный плагин Перейти по ссылке который создан специально для устранения конфликта jquery.
    Перейти по ссылке
    Вот он то и пришел мне на помощь! Я откровенно не ожидал, что все так сложиться, но на мое глубокое удивление после установки и активации плагина все заработало на ура!
    Плагин является бесплатным и доступен для загрузки после регистрации на сайте.
    дополнительно выложил на обменник для удобства

    возможно и в других случаях этот чудо плагин сработает, но я пока не успел проверить. Надеюсь вам он тоже поможет!

    Удачи!
     
    Последнее редактирование: 16 май 2014
    arma7 и SnakeXP нравится это.
  2. korkunov

    korkunov

    Регистр.:
    6 фев 2009
    Сообщения:
    306
    Симпатии:
    82
    Вы забыли указать,что он только для Joomla 2.5
     
  3. Etc2

    Etc2 Создатель

    Регистр.:
    22 июл 2014
    Сообщения:
    16
    Симпатии:
    0
    Хотел попробовать, чтоб избавиться от обычного глюка у лайтбокса/шадоубокса, однако на установке на J2.5.6 выдает ошибку. Придется опять костылить с гугловским jquerry.
     
  4. spro1

    spro1

    Регистр.:
    26 май 2013
    Сообщения:
    170
    Симпатии:
    70
    Etc2 нравится это.
  5. mdigital.md

    mdigital.md Писатель

    Регистр.:
    11 авг 2014
    Сообщения:
    4
    Симпатии:
    0
    Как обычно у всех компонентах у всех плагинов есть в настройке опция отключения загрузки библиотек, это лучший способ либо если надо дописать или исправить конфликт я например пользуюсь
    $jQ = jQuery.noConflict();
    $jQ(document).ready(function() {
    // код
    });
     
  6. skydimas

    skydimas Создатель

    Регистр.:
    14 авг 2012
    Сообщения:
    38
    Симпатии:
    9
    Это альтернатива плагину Перейти по ссылке, подходящая для Joomla 3 в том функционале, что Вы описали в первом посте? Или если нет, то может что-то "вычленить" из из работы первого плагина, например, какой именно код "разруливает" конфликт? Или по опыту mdigital.md $jQ = jQuery.noConflict(); "разруливает" все?
     
  7. fenix-77

    fenix-77

    Регистр.:
    18 мар 2014
    Сообщения:
    159
    Симпатии:
    60
    Мне помог Перейти по ссылке. Только нужно покопать в настройках. )
     
  8. Mironov91

    Mironov91 Постоялец

    Регистр.:
    13 май 2014
    Сообщения:
    51
    Симпатии:
    3
    В JQuery лучше скрипты выше 1.9.1 версии не ставить. Товарищ Internet Explorer перестаёт их переваривать. В своё время запутало меня это. В плагине, кстати, большой плюс в том что библиотеки скриптов можно из онлайна брать.
     
    blZ нравится это.
  9. Uriys

    Uriys Постоялец

    Регистр.:
    21 июн 2011
    Сообщения:
    51
    Симпатии:
    0
    Да спасибо помогло, а какую версию JQuery использовать для новых расширений? если 1.9.1 конфликтирует с Internet Explorer то какая актуальнее всего?
     
  10. Mironov91

    Mironov91 Постоялец

    Регистр.:
    13 май 2014
    Сообщения:
    51
    Симпатии:
    3
    Вы не поняли, 1.9.1 можно ещё. Выше уже ставить не стоит.