Проблема с настройкой apache2 [Debian]

Тема в разделе "Администрирование серверов", создана пользователем m1ko, 31 мар 2014.

Модераторы: mefish, stooper
  1. m1ko

    m1ko Создатель

    Регистр.:
    15 авг 2010
    Сообщения:
    42
    Симпатии:
    3
    В общем уже почти год работает связка apache2 + nginx все хорошо все устраивает.
    На сервере имеется несколько разных сайтов, есть одна проблема, выключаю 1 сайт a2dissite название сайта, захожу на него, он мне подставляет другой, выключаю так же тот который подставляю, он опять другой подставляет. как сделать так что бы если я сайт выключил он ничего другого не выдавал.
    Я гуглить уже устал ответов нет..
     
  2. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    924
    Симпатии:
    646
    есть такая штука, как server_name, для пущей верности прописываем в /etc/hosts свои два домена, дабы отбросить проблемы с резолвом. Думаю направление дал верно.
     
  3. m1ko

    m1ko Создатель

    Регистр.:
    15 авг 2010
    Сообщения:
    42
    Симпатии:
    3
    Я не совсем понял что это даст, а что если у меня больше 10 сайтов, и некоторые прописаны полностью всей зоной *.site.ru
    и причем тут server_name? это часть nginx, мне нежно устранить проблему для начало в apache не трогая nginx
     
  4. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    924
    Симпатии:
    646
    Тогда для начала предоставьте конфиги apache и nginx.
     
  5. m1ko

    m1ko Создатель

    Регистр.:
    15 авг 2010
    Сообщения:
    42
    Симпатии:
    3
    nginx не причем, я проверяю это на порту 8080 на прямую к апачу.

    ports.conf
    NameVirtualHost *:8080
    Listen 8080

    <IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
    </IfModule>

    <IfModule mod_gnutls.c>
    Listen 443


    sites-available/intomv.ru
    <VirtualHost * (*:8080 пробовал)>
    DocumentRoot "/home/instashit/web/instashit/html
    ServerAdmin support@admin.ru
    AddDefaultCharset UTF-8
    ServerName intomv.ru
    ServerAlias www.intomv.ru
    LogLevel warn
    CustomLog /home/instashit/web/instashit/logs/access.log common
    ErrorLog /home/instashit/web/instashit/logs/error.log
    <Directory /home/instashit/web/instashit/html/>
    php_admin_value open_basedir "/home/instashit/web/instashit:."
    php_admin_value upload_tmp_dir "/home/instashit/web/instashit/tmp"
    php_admin_value session.save_path "/home/instashit/web/instashit/tmp"
    #Order Deny,Allow
    #Deny from all
    Options -ExecCGI -Indexes -Includes +FollowSymLinks
    AllowOverride All
    <Limit GET POST>
    Order allow,deny
    Allow from all
    </Limit>
    <LimitExcept GET POST>
    Order deny,allow
    Deny from all
    </LimitExcept>
    </Directory>
    </VirtualHost>
     
  6. dwarf

    dwarf Постоялец

    Регистр.:
    12 июн 2011
    Сообщения:
    88
    Симпатии:
    18
    У вас должно быть в апаче сконфигурировано сейчас 2 виртуалхоста. Для первого домена, и для второго.
    Вы убираете один из вируалхостов и все запросы на домен этого виртуалхоста начинают валиться на первый виртуалост. Правильно?
    Если все так, перед этими двумя виртуалохостами нужно добавить третий:
    Код:
    <VirtualHost *>
    DocumentRoot /var/www/defaulthost
    </VirtualHost>
    и все запросы, которые не сматчатся, будут попадать в него
     
    m1ko нравится это.
  7. m1ko

    m1ko Создатель

    Регистр.:
    15 авг 2010
    Сообщения:
    42
    Симпатии:
    3
    Я думал о подобном, помести этот код в default и включил его, теперь вроде все работает как нужно, спасибо огромное! Я думал никто уже не поможет...
     
  8. m1ko

    m1ko Создатель

    Регистр.:
    15 авг 2010
    Сообщения:
    42
    Симпатии:
    3
    <VirtualHost 192.168.0.100:8080>
    DocumentRoot /var/www/
    </VirtualHost>
    Вот с моим локальным IP заработало так как нужно!! там еще дописал пару строк для удобства. всем спасибо за помощь, у кого такая же проблема, пользуемся)
     
    Последнее редактирование: 1 апр 2014