Opencart + TecDoc

Тема в разделе "Opencart", создана пользователем KOZMO, 22 окт 2013.

Информация :
Внимание форумчане! При создании тем, или выкладывании какой-либо информации проверьте в какой ветке форума вы находитесь! Не путайте Opencart и Opencart2. При несоблюдении данного условия выносится соответствующее наказание! И потом не говорите что вас НЕ ПРЕДУПРЕЖДАЛИ! По возможности используйте обменники mail, yandex, google, dropbox, rghost Дабы избежать просьб перезалить и проблем с рекламой!
  1. maccenon

    maccenon

    Регистр.:
    25 дек 2013
    Сообщения:
    1.084
    Симпатии:
    210
    перевод сделайте сами, а базу воспользуйтесь поиском гугла, или почитайте тему
     
  2. Wishksv

    Wishksv Постоялец

    Регистр.:
    21 июл 2015
    Сообщения:
    60
    Симпатии:
    9
    У меня есть и база и модуль на нужном вам языке, обращайтесь помогу.
     
  3. wokenjorts

    wokenjorts Создатель

    Регистр.:
    9 авг 2018
    Сообщения:
    14
    Симпатии:
    2
    Возможно кому пригодится: Модуль TECDOC 3.2.5 на основе 3.0.15 - 3.2.4 - 3.2.5 переписан под bootstrap, адаптирован под тему PixelShop.
     
  4. Wishksv

    Wishksv Постоялец

    Регистр.:
    21 июл 2015
    Сообщения:
    60
    Симпатии:
    9
    в модуле уязвимость))) большая дыра в безопасности.
     
  5. wokenjorts

    wokenjorts Создатель

    Регистр.:
    9 авг 2018
    Сообщения:
    14
    Симпатии:
    2
    Этот пока единственный в свободном доступе, если есть без дыры, то поделитесь пожалуйста на форму со всеми.
     
  6. Wishksv

    Wishksv Постоялец

    Регистр.:
    21 июл 2015
    Сообщения:
    60
    Симпатии:
    9
    я декодировал всё сам, поделиться с людьми который через час будут продавать его как свое решение? я окажу помочь лишь тем кто действительно участвовал в развитии темы (а не тырил где-то что-то и якобы делился)
     
    maccenon, DATANET и davyduck нравится это.
  7. wokenjorts

    wokenjorts Создатель

    Регистр.:
    9 авг 2018
    Сообщения:
    14
    Симпатии:
    2
    Говорит человек на форуме с нулами про "тыреный" модуль у автора. Вот 100% уверен что многие в этой теме кто топит за то что буду делиться с "избранными" не раз его продали таким же "избранным". Ничего против "труд должен оплачиваться" не имею, но называйте вещи своими именами и не обвиняйте других :lol: А так и говорите "поделюсь за вознаграждение"
     
  8. davyduck

    davyduck

    Регистр.:
    18 дек 2012
    Сообщения:
    696
    Симпатии:
    148
    Ну попрошу Вас не путать грешное и праведное. У многих модуль модифицирован. Вот, например, у меня - http://e-bolt.com.ua/ . Что тут тыряно у Влада? картинки? Часть запросов? Базовая структура? Но я переписал 80% модуля. Многое добавил, упростил, защитил. Так же и другие люди в этой теме. И если люди вкладывали в развитие время, деньги, силы - то почему плохо, что мы берем деньги за свою работу? Многие знают, как я предложил в этой теме, декодировать 3 модуль. Мне сказали, что это не реально. И когда я вбухал деньги в модуль, в декод, мы его с Маккеноном отвязали и выклали бессплатно - все были довольны. На 3.0.0.8 и 3.0.015 появились другие альтруисты. Мы тратили деньги, делали, правили и бессплатно выкладывали. Всем было хорошо. А потом барыги (по другому не назву) брали тут и продавали. Да и не просто продавали. а ставили себя разрабами, прогерами, спецами. А сами даже базу поставить не могли и банальную проблему с дискрипшином решить не могли (олды поймут). И вот когда барыги достали, старожилы запротестовали и перестали давать свои решения халявщикам - вот стало плохо. Новых версий почти не у кого нету. И разрабов стало меньше. Ведь ничего не изменилось то - делаешь сайт себе? - бессплатно дам модуль. Но 3.0.15. И так многие. Хочешь поиграть в бизнесмена - вложи деньги. получишь и тех поддержку, и обновления, и лучшие наработки. Лично у меня, год назад был магазин с посещаемость 2500 уников в сутки. И это на 3.0.15. Так что для старта вполне хватает этой версии. Заработаете денег - обновитесь. А то все хотят сразу, халявы, а потом еще и перепродать чужое решение, заработав на нем денег. Нельзя так, не правильно.

    p.s. Сори за флуд, накипело. Каждый день от 1 до 3 людей обращается с просьбой дать что-то бессплатно. Ты даешь, помогаешь, настраиваешь, а потом они на этом же форуме его продают.
     
    maccenon, shutle, DATANET и ещё 1-му нравится это.
  9. pitac

    pitac Писатель

    Регистр.:
    21 авг 2019
    Сообщения:
    6
    Симпатии:
    3
    Добрый день.
    Я так понимаю в комплекте с модулем 3.0.15 файлы для интерграции в опенкарт 2.1? При попытке установки на 2.3 отваливается корзина
    SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
    OK
    <br />
    Код:
    <b>Fatal error</b>: Uncaught exception 'Exception' with message 'Error: Could not load model total/sub_total!' in /system/storage/modification/system/engine/loader.php:59
    Stack trace:
    #0 /catalog/controller/checkout/cart.php(377:( Loader-&gt;model('total/sub_total')
    #1 [internal function]: ControllerCheckoutCart-&gt;add()
    #2 /system/storage/modification/system/engine/action.php(51:( call_user_func_array(Array, Array)
    #3 /catalog/controller/startup/router.php(25:( Action-&gt;execute(Object(Registry))
    #4 [internal function]: ControllerStartupRouter-&gt;index()
    #5 /system/storage/modification/system/engine/action.php(51:( call_user_func_array(Array, Array)
    #6 /system/engine/front.php(34:( Action-&gt;execute(Object(Registry))
    #7 /system/engine/front.php(29:( Front-&gt;execute(Object(Action))
    #8 /system/framework.php(103:( Front-&gt;dispatch(Object(Action), Object(Action))
    #9 /system/startup.php in <b>/system/storage/modification/system/engine/loader.php</b> on line <b>59</b><br />
    Проблема именно после замены файла /catalog/controller/checkout/cart.php

    Возможно у кого-то есть файлы интеграции для 2.3?
    Поставить опенкарт 2.1 нет возможности, уже куплен шаблон под 2.3, а он не работает под 2.1
     
    Последнее редактирование модератором: 11 сен 2019
  10. Wishksv

    Wishksv Постоялец

    Регистр.:
    21 июл 2015
    Сообщения:
    60
    Симпатии:
    9
    Посмотрите запросы в контроллере и подправьте под версию 2.3 они не сильно отличаются...