1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Помощь Не отображаются изображения из определенных папок

Тема в разделе "Joomla", создана пользователем pragmatik, 14 окт 2013.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, NightHunter
  1. pragmatik

    pragmatik Постоялец

    Регистр.:
    12 фев 2013
    Сообщения:
    125
    Симпатии:
    32
    предыстория:
    установил последний дистрибутив 2.5 с официального сайта,
    из сторонних расширений:
    • накатил шаблон YT Nano3
    • установил xmap и плагин для экранирования внешних ссылок
    отключил редакторы кода.

    описание проблемы:
    вставляю в материал картинку <p style="text-align: justify;"><img src="images/obzor/1.jpg" border="0" alt="1" /></p> - отлично отображается, рядом с ней вставляю картинку из другой папки сайта <p style="text-align: justify;"><img src="images/obzor/reklama/1/1.jpg" border="0" alt="1" /></p> - не отображается
    cmod файлов и папок идентичны;
    если с фронтенда просматривать код, то можно перейти по второй ссылке, т.е. ссылка корректная;
    если просматривать код через инспектирование элементов mozilla то рядом с неработающей картинкой можно видеть атрибут class="yuoficcpzegsctgbowko"

    попытки конкретизировать проблему:
    • добавляю ту же картинку в первую папку, из которой нормально отображалась другая картинка - отображается;
    • меняю шаблон на другой, от другой студии - не отображается, при этом так же дописывается class="yuoficcpzegsctgbowko".
    Работаю с Joomla не первый год, никогда с подобным не сталкивался. Интересно разобраться. Буду признателен за здравые идеи. Если проблема с хостингом, то почему дописывается class="yuoficcpzegsctgbowko" и почему файл доступен по прямой ссылке? Если с каким-то расширением, то почему оно только на файлы определенной папки реагирует?
     
  2. JohnLemon

    JohnLemon Постоялец

    Регистр.:
    3 окт 2013
    Сообщения:
    52
    Симпатии:
    3
    Скорее всего дело в том что у тебя второе изображение находиться уже в других вложенных папках, возможно проблема из за настроек .htaccess попробуй вообще переименовать его и проверить. По прямой ссылке через браузер картинка открывается ???
     
  3. pragmatik

    pragmatik Постоялец

    Регистр.:
    12 фев 2013
    Сообщения:
    125
    Симпатии:
    32
    опять же, внимательно читайте вопросы, перед тем как на них отвечать, в вопросе было сказано:
    решение проблемы обнаружилось совершенно случайно,
    у меня в 3х браузерах, в которых я тестирую работоспособность сайтов, установлено расширение AdBlock,
    а путь к изображению содержал слово "reklama", из-за чего его отображение и блокировалось этим расширением
     
Статус темы:
Закрыта.