Помощь Настройка Push and Pull

Тема в разделе "Битрикс", создана пользователем alekse, 10 сен 2013.

Модераторы: mrLom, puagardian
  1. alekse

    alekse

    Регистр.:
    19 июн 2007
    Сообщения:
    694
    Симпатии:
    120
    Прошу помощи по настройке модуля "Push and Pull" корпоративного портала. NGINX работает, установлен с модулем nginx-push-stream-module Что и как нужно еще настроить? В мануале написано, что нужно еще добавить записи в nginx.conf - добавил и не работает. Есть у кого реальный пример, с виртуалки по конфигам не разберусь никак.
     
  2. gera111

    gera111 Постоялец

    Регистр.:
    1 окт 2008
    Сообщения:
    149
    Симпатии:
    13
    Другая проблема - не собирается Ngix с nginx-push-stream ((( Вернее, всё ок, но при проверке nginx -V модуля в списке нет. Чтобы не плодить темы решил спросить здесь. Надеюсь, ТС не будет против...
     
  3. EskinS

    EskinS Постоялец

    Регистр.:
    1 фев 2009
    Сообщения:
    54
    Симпатии:
    10
    Поставь виртуальную машину Bitrix. В ней сразу все настроено.
     
  4. gera111

    gera111 Постоялец

    Регистр.:
    1 окт 2008
    Сообщения:
    149
    Симпатии:
    13
    Не вариант. На сервере много проектов, управляется ISP. Только физика, на виртуалки не разбит. Гробить всё, что работает почти два года из-за одного внутреннего портала - некомильфо. А адекватно пересобрать nginx нифига не получается. Вторые сутки с ним бьюсь. ВСЕ модули работают, ставятся - удаляются, а push-stream ни в какую. Грешу на кривизну рук.
     
  5. mrLom

    mrLom ♒︎

    Moderator
    Регистр.:
    24 дек 2014
    Сообщения:
    822
    Симпатии:
    1.403
    Куда быстрее было бы получить помощь, если бы вы описали чего у вас за операционка, в какой редакции и разрядности. Но как вариант — можно погадать на кофейной гуще.
    Так что быстренько выкладываем версии сборки и ядра:
    Код:
    1. $ cat /etc/*release*
    2. $ uname -a
    
     
  6. gera111

    gera111 Постоялец

    Регистр.:
    1 окт 2008
    Сообщения:
    149
    Симпатии:
    13
    Сорри за долгий ответ, выезжал.
    Код:
    ***@server:~$ cat /etc/*release*
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"
    NAME="Ubuntu"
    VERSION="14.04.3 LTS, Trusty Tahr"
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME="Ubuntu 14.04.3 LTS"
    VERSION_ID="14.04"
    HOME_URL="http://www.ubuntu.com/"
    SUPPORT_URL="http://help.ubuntu.com/"
    BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
    ***@server:~$ uname -a
    Linux server.***.ru 3.19.0-28-generic #30~14.04.1-Ubuntu SMP Tue Sep 1 09:32:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
    
     
  7. gera111

    gera111 Постоялец

    Регистр.:
    1 окт 2008
    Сообщения:
    149
    Симпатии:
    13
    Блин, хоть разбивай на виртуалки, пересобрал аж четыре версии Nginx - ни на одной p&p не заработал
     
  8. Swyatogor

    Swyatogor Писатель

    Регистр.:
    2 дек 2016
    Сообщения:
    1
    Симпатии:
    0
    Всем привет.. Можно тут присоседиться?
    Вопрос возник такого плана - поставил виртуалку от битрикса для тестов.. стал пробовать.. вроде все работало.. но при попытке отрубить интернет (перенести в зону без интернета для локального внутри сети использования) отрубается push&pull..
    это так и должно быть и не лечится или что то где то нужно еще допилить?