Портятся фото при загрузке

Тема в разделе "Мегафлуд", создана пользователем Waki, 26 июл 2013.

  1. Waki

    Waki Постоялец

    Регистр.:
    14 ноя 2012
    Сообщения:
    64
    Симпатии:
    21
    На сайте фото иногда загружаются так
    [​IMG]
    Вначале думал что из-за ватермарка такая проблема, отключил, не помогло. Далее попробовал отключить ресайз изображений, т.е. чтобы загружал их таким размером как есть, но и это не помогло.
    Подскажите, как можно это исправить?
     
  2. enrik

    enrik Создатель

    Регистр.:
    5 июн 2013
    Сообщения:
    11
    Симпатии:
    4
    Ну у тебя картинка после загрузки на сайт выводится без скриптом без обработки ? Если никакой обработки с файлом нет, то копать надо в сторону загрузки файлов на сервер. Чем загружаешь, и проверь сумму хэша файла до и после загрузки на сервер. По моему бьётся он у тебя при передаче на сервер.
     
  3. Waki

    Waki Постоялец

    Регистр.:
    14 ноя 2012
    Сообщения:
    64
    Симпатии:
    21
    Картинка выводится без обработки, на сервере создается только четыре миниатюры, разных размеров (создаются из основного фото, поэтому если оно битое, то и миниатюры такие же).
    Но такая проблема не всегда, иногда загружается нормально, бывают подадут 100 объявлений и будет все ок, а бывает сразу несколько портятся, поэтому сложно отловить в чем ошибка.
     
    fairbug нравится это.
  4. fairbug

    fairbug

    Регистр.:
    1 май 2013
    Сообщения:
    185
    Симпатии:
    64
    попробуй в файл httpd.conf прописать - CharsetRecodeMultipartForms Off
     
  5. korishok

    korishok Писатель

    Регистр.:
    27 окт 2011
    Сообщения:
    4
    Симпатии:
    0

    У меня такое бывает, когда скорость интернета у клиентов слабенькая (сайт по печати фотографий), фото не успевает загрузиться на сервер и происходит обрыв. Редко конечно бывает, но бывает.