Редирект, а потом анонимизация в XenForo

Тема в разделе "XenForo", создана пользователем quzexk, 17 июл 2013.

Информация :
Хотите добавить продукт, следуйте правилам:
1)Добавить скриншот.
2)Добавить описание (Описание на английском языке использовать - запрещено).
3)Ссылка на скачивание должна вести на сторонний файлообменник (использовать вложения - запрещено).
Модераторы: DMS
  1. quzexk

    quzexk Постоялец

    Регистр.:
    27 авг 2007
    Сообщения:
    78
    Симпатии:
    42
    Хочу настроить XenForo так, чтобы всем ссылки имеющие класс
    Код:
    a class="externalLink" rel="nofollow" target="_blank"
    Присваивался редирект, а потом перебрасывался на аноним.то
    /redirect/?url=http://anonym.to/

    Как у нас на нулледе. Те редирект через _blank на страничку, а потом на http://anonym.to/
     
  2. Bezhev

    Bezhev

    Регистр.:
    26 дек 2012
    Сообщения:
    364
    Симпатии:
    124
  3. quzexk

    quzexk Постоялец

    Регистр.:
    27 авг 2007
    Сообщения:
    78
    Симпатии:
    42
    ssllav нравится это.
  4. Bezhev

    Bezhev

    Регистр.:
    26 дек 2012
    Сообщения:
    364
    Симпатии:
    124
  5. aligon7

    aligon7

    Регистр.:
    19 май 2012
    Сообщения:
    252
    Симпатии:
    121
    чтото не работает как у вас, работает только ананим . то
     
  6. ssllav

    ssllav Создатель

    Регистр.:
    19 фев 2009
    Сообщения:
    40
    Симпатии:
    6
    Сделал так.
    Открываем к редактированию файл Listener.php из папки xencode
    и 12ую строчку привел к виду добавив после префикс анонима:
    Код:
    if($options->useFriendlyUrls) { $redirector = $options->boardUrl.'/redirect/?url=http://anonym.to/?'; } else { $redirector = $options->boardUrl.'/index.php?redirect/?url=http://anonym.to/?'; }
    Теперь работает через внутренний редирект и аноним.то правильно.
    В настройках стоит автоперенаправление.
    Знающие люди посмотрите плз, а то может кому и пригодится.
     
    Последнее редактирование: 11 дек 2013