1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Помощь Обновление с 1.5.26 до 2.5

Тема в разделе "Joomla", создана пользователем penguen, 29 май 2013.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. penguen

    penguen

    Регистр.:
    7 янв 2007
    Сообщения:
    821
    Симпатии:
    93
    Всем добрый день
    Задача: Обновить действующий сайт до версии 2.5
    Что имеем. Сайт на движке Джумла 1.5.26
    Установленный компонент - jUpgrade версии 2.5.2
    ======================================
    При обновлении выдает кучу ошибок
    ----------------------------------------------------------
    Лог дебага в процессе переноса прилагаю

    ==========
    [checks]
    1
    ==========
    [cleanup]

    1
    ==========
    [decompress]

    1
    ==========
    [install_config]

    1
    ==========
    [install_db]

    ==========
    [1] [users]
    ==========
    [2] [categories]

    ==========
    [3] [content]

    JLIB_DATABASE_ERROR_ARTICLE_UNIQUE_ALIAS

    ==========
    [4] [menus].

    ==========
    [5] [modules]

    ==========
    [6] [banners]
    ==========
    [7] [contacts]

    ==========
    [8] [newsfeeds]

    ==========
    [9] [weblinks]

    ==========
    [files]
    ==========
    [10] [extensions]

    ;|;10;|;extensions;|;11

    ==========
    [11] [com_comprofiler]

    ;|;11;|;com_comprofiler;|;18

    ==========
    [12] [com_jce]

    ;|;12;|;com_jce;|;18

    ==========
    [13] [com_acymailing]

    Duplicate entry '1306' for key 'PRIMARY' SQL=INSERT INTO j25_acymailing_subscriber SELECT * FROM jos_acymailing_subscriber;|;13;|;com_acymailing;|;18

    ==========
    [14] [com_kunena]

    ;|;14;|;com_kunena;|;18

    ==========
    [15] [com_jcomments]

    ;|;15;|;com_jcomments;|;18

    ==========
    [16] [com_akeeba]

    ;|;16;|;com_akeeba;|;18

    ==========
    [17] [com_xmap]

    ;|;17;|;com_xmap;|;18

    ==========
    [18] [ready]

    ;|;18;|;ready;|;18

    Первое что не перенесло это контент, там порядка 360 статей. Как быть хз. Посмотрел в гугл. Толком нуль. Может вы что-то подскажете. Т.к. сайт давно не кто не обновлял.
     
  2. win32

    win32

    Заблокирован
    Регистр.:
    17 июн 2008
    Сообщения:
    328
    Симпатии:
    192
    сначала надо обновиться до версии 1.7 , с неё уже до 2.5
     
  3. penguen

    penguen

    Регистр.:
    7 янв 2007
    Сообщения:
    821
    Симпатии:
    93
    В доке по jupgrade 2.5.2 написано, что можно с 1.5.26 обновляться до 2.5.6
     
    Akadmon нравится это.
  4. Lawer

    Lawer Создатель

    Регистр.:
    2 апр 2013
    Сообщения:
    36
    Симпатии:
    38

    Судя по всему дублируются синонимы статей, такого быть не должно.

    По поводу com_acymailing, то мигрировать без него и использовать для него другие скрипты миграции.
    Скорее всего в нем должна быть функция бекапа и восстановления.
     
  5. traintop

    traintop Постоялец

    Регистр.:
    13 сен 2008
    Сообщения:
    50
    Симпатии:
    1
    penguen, в процессе обновления доходит до шага "Сайт обновлен"?
     
  6. eozee

    eozee Постоялец

    Регистр.:
    26 авг 2007
    Сообщения:
    65
    Симпатии:
    3
    Если просто контент перенести, то я рекомендую компонент SP Upgrade (на форуме имеется). Дважды пыталась переносить сайты jUpgrade и каждый раз что-то глючило, с spupgrade все прошло как по маслу.
     
  7. penguen

    penguen

    Регистр.:
    7 янв 2007
    Сообщения:
    821
    Симпатии:
    93
    нет не до ходило.
     
  8. traintop

    traintop Постоялец

    Регистр.:
    13 сен 2008
    Сообщения:
    50
    Симпатии:
    1
    Тогда скачайте последний дистрибутив Joomla 2.5 и залейте его в папку jupgrade.
    В настройках компонента jUpgrade 2.5.2 отметьте чтобы пропустило шаги скачивания и распаковки.

    Дальше, если процесс миграции при нажатии не начнется, то возможно проблема в хостинге.
    Если процесс миграции начнется, то все должно обновится нормально.
     
  9. BioNicle

    BioNicle Постоялец

    Регистр.:
    15 июн 2012
    Сообщения:
    52
    Симпатии:
    11
    У меня вообще не получилось каким-либо образом через jUpgrade такое провернуть, ковырялся, ковырялся, не смог разобраться в чем причина.

    Потом просто архив с 2.5.6_update загрузил через расширения и джумла сама обновилась ))) Чудеса, попробуй, только не забывай про бэкапы, вдруг чего не так, у меня, где делал, пара компонентов джумлы так и не обновляется до сих пор, но они там и не нужны.
     
  10. traintop

    traintop Постоялец

    Регистр.:
    13 сен 2008
    Сообщения:
    50
    Симпатии:
    1
    Ну так у вас видимо версия была 1.7 или выше, раз обновилось через расширения.
     
Статус темы:
Закрыта.