Как устранить конфликты между разными версиями jquery?!

Тема в разделе "JavaScript", создана пользователем Denis_Pi, 19 апр 2013.

Статус темы:
Закрыта.
Модераторы: ZiX
  1. Denis_Pi

    Denis_Pi Art сreator

    Заблокирован
    Регистр.:
    8 май 2012
    Сообщения:
    398
    Симпатии:
    214
    :dead: Это какой то пистецЫд в скрипте куча jquery натягиваю новую шкуру со своими jquery библиотеками, а они все до единой в конфликте=(( как быть может быть есть какой нибудь удобный и оперативный выход?
     
  2. stasionok

    stasionok

    Регистр.:
    29 ноя 2012
    Сообщения:
    287
    Симпатии:
    315
  3. nethare

    nethare Постоялец

    Регистр.:
    27 окт 2012
    Сообщения:
    104
    Симпатии:
    30
    А поконкретнее можно? Лог ошибок хотя бы.

    Используя эту штуку ему ТСу равно придется переписывать каждый из своих скриптов.
     
  4. Denis_Pi

    Denis_Pi Art сreator

    Заблокирован
    Регистр.:
    8 май 2012
    Сообщения:
    398
    Симпатии:
    214
    Ну во первых nethare - прав, используя ноу конфликт мне придется переписать все имеющиеся jquery или в шкуре или в системе - вы не представляете сколько их много)
    во вторых если мне память не изменяет то ноуконфликт в основном используется для устранения конфликтов между jquery и мототулс

    Я сейчас не на месте - завтра опубликую некоторые - а какой выход можете предложить!?
     
  5. nethare

    nethare Постоялец

    Регистр.:
    27 окт 2012
    Сообщения:
    104
    Симпатии:
    30
    Смотреть надо на конкретные ошибки, так просто ничего нельзя сказать.

    Может вы раньше использовали древнюю jQuery, а плагины под новую, может там везде переменные переопределяются по 5 раз..

    Или покажите ошибки, или дайте ссылку где это все у вас лежит и не работает:)
     
  6. Denis_Pi

    Denis_Pi Art сreator

    Заблокирован
    Регистр.:
    8 май 2012
    Сообщения:
    398
    Симпатии:
    214
    так и есть!( вот и спрашиваю, должен же ведь быть более менее автоматизированный способ - !) по крайней мере я на это очень надеюсь...
     
  7. Demuri

    Demuri Постоялец

    Регистр.:
    6 мар 2009
    Сообщения:
    59
    Симпатии:
    3
    jQuery migration tool - не то?
    Кстати, jQuery 2.0.0 вышла. Без поддержки IE 6-8. Ветка 1.9 еще пару лет будет поддерживаться.
     
  8. nethare

    nethare Постоялец

    Регистр.:
    27 окт 2012
    Сообщения:
    104
    Симпатии:
    30
    А можно ссылочку на migration tool? Гугл ничего не выдал по запросу:(

    Для ТС: ошибки в студию:) Честно, в автоматизированные способы верю слабо, но может, и получится что-нибудь универсальное придумать.
     
  9. Denis_Pi

    Denis_Pi Art сreator

    Заблокирован
    Регистр.:
    8 май 2012
    Сообщения:
    398
    Симпатии:
    214
    Вот вроде бы http://jquery.com/upgrade-guide/1.9/
     
  10. nethare

    nethare Постоялец

    Регистр.:
    27 окт 2012
    Сообщения:
    104
    Симпатии:
    30

    Это список обновлений. Это списки читать первым делом надо при обновлениях. Можно кстати попробовать подключить плагин

    <script src="http://code.jquery.com/jquery-migrate-1.1.1.js"></script>
     
Статус темы:
Закрыта.