DataLife Engine v.9.8 и версия PHP

Тема в разделе "Администрирование серверов", создана пользователем majela, 29 мар 2013.

Модераторы: mefish, stooper
  1. majela

    majela Писатель

    Заблокирован
    Регистр.:
    22 мар 2013
    Сообщения:
    9
    Симпатии:
    0
    Обновил сайт сегодня когда в админке захожу так пишет

    Внимание!
    Версия PHP, установленная на сервере, устарела. Часть функций скрипта с этой версией PHP будет недоступна, поэтому мы рекомендуем связаться с администрацией хостинга для обновления версии PHP! Рекомендуемая версия PHP для работы скрипта не ниже 5.1. Скачать последнюю версию можно на Перейти по ссылке.

    у меня выделенный сервер. я сам могу исправит или написат в тех поддержку ?
     
  2. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.175
    Симпатии:
    2.195
    Тема перемещена из раздела DLE в раздел Администрирование серверов.

    Слишком мало информации. Вы можете сделать всё сами, но Вам нужно для этого уметь это сделать. Для совета нужно как минимум:
    1) Версия php
    2) Версия ОС
     
    majela нравится это.
  3. majela

    majela Писатель

    Заблокирован
    Регистр.:
    22 мар 2013
    Сообщения:
    9
    Симпатии:
    0
    Операционная система: CentOS 5.7 32 bit

    А версия php
    PHP Version 5.1.6
     
  4. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    858
    Симпатии:
    621
    В консоле запускаеш по очередно следующие команды:

    Пых будет версии 5.2.17

    Код:
    rpm -ihv http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
     
    rpm -ihv http://centos.alt.ru/repository/centos/5/i386/centalt-release-5-3.noarch.rpm
     
    yum clean all
     
    yum update
    
     
    Горбушка и majela нравится это.
  5. majela

    majela Писатель

    Заблокирован
    Регистр.:
    22 мар 2013
    Сообщения:
    9
    Симпатии:
    0
    Я не очень хорошо разбираюсь

    У меня уже установлен несколько сайтов на этом сервере.. если обновлю сайты не пострадают?
     
  6. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    858
    Симпатии:
    621
    Нет, не пострадают, если что, стучись 475207706
     
    majela нравится это.
  7. invader

    invader Серый кардинал в отставке :)

    Moderator
    • Супермодератор
    Регистр.:
    3 апр 2006
    Сообщения:
    2.760
    Симпатии:
    5.761
    Могут пострадать, если в движках сайтов используются устаревшие функции
     
  8. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    858
    Симпатии:
    621
    invader

    ТС не указал, что кроме дле крутиться, тем более я дал свой контакт, для пущей надежности.
     
  9. majela

    majela Писатель

    Заблокирован
    Регистр.:
    22 мар 2013
    Сообщения:
    9
    Симпатии:
    0
    Я сделал точно так использовал программу putty но не обновился опять показывает так

    php-5.1.6-39.el5_8
     
  10. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    858
    Симпатии:
    621
    Стучись в аську, я же не просто так ее написал, или на 5 страниц сейчас растянем тему как обновить php.