[Помогите] Проблема с выводом more

Тема в разделе "Wordpress", создана пользователем dimabik, 14 фев 2013.

Статус темы:
Закрыта.
Модераторы: Sorcus
  1. dimabik

    dimabik

    Регистр.:
    14 мар 2008
    Сообщения:
    964
    Симпатии:
    180
    Вот такая проблема возникла на сайте с шаблоном и стандартные методы в сети не помогают

    Выводится
    А нужно чтобы правильно
     
  2. TonyC

    TonyC

    Регистр.:
    6 мар 2008
    Сообщения:
    204
    Симпатии:
    88
    В functions.php пробовали добавлять код?
    Код:
    <?php
        function remove_more_tags($link) {
            $offset = strpos($link, '#more-');
            if ($offset) {
                $end = strpos($link, '"',$offset);
            }
            if ($end) {
                $link = substr_replace($link, '', $offset, $end-$offset);
            }
            return $link;
        }
        add_filter('the_content_more_link', 'remove_more_tags');
        ?>
     
  3. dimabik

    dimabik

    Регистр.:
    14 мар 2008
    Сообщения:
    964
    Симпатии:
    180
    Это который в папке в wp-includes не в шаблоне?
     
  4. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    Закиньте тот код, что писал Tonyc в файл functions.php темы
     
  5. TonyC

    TonyC

    Регистр.:
    6 мар 2008
    Сообщения:
    204
    Симпатии:
    88
    Да, в файл шаблона.
     
  6. dimabik

    dimabik

    Регистр.:
    14 мар 2008
    Сообщения:
    964
    Симпатии:
    180
    Cделал толку никакого, тема GamesBlog: я поэтому и отписался что в сети ни нашел стандартное не помогает
    Вот сама тема
     
  7. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    Файл post.php внизу смотрите
    PHP:
    <?php if($theme->display('read_more')) { ?>
            <div class="readmore">
                <a href="<?php the_permalink(); ?>#more-<?php the_ID(); ?>" title="<?php printfesc_attr__'Permalink to %s''themater' ), the_title_attribute'echo=0' ) ); ?>" rel="bookmark"><?php $theme->option('read_more'); ?></a>
            </div>
            <?php ?>
    Обратите внимание на #more-<?php the_ID(); ?>
    Его удалите. Проверьте в остальных файлах шаблона. Может еще есть подобная конструкция
     
    dimabik нравится это.
  8. dimabik

    dimabik

    Регистр.:
    14 мар 2008
    Сообщения:
    964
    Симпатии:
    180
    Да именно он и делал проблему. Все решилось. Вот что значит умелый взгляд на такие вещи. Спасибо за помощь.
     
Статус темы:
Закрыта.